Modify

Opened 9 years ago

Closed 9 years ago

#2206 closed defect (duplicate)

uclibc build seems broken for broadcom - mipsel-unknown-linux-uclibc ?

Reported by: cinober Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Last couple of days was/is impossible to build images for WL500w.

mipsel-unknown-linux-uclibc ? It used to be something like mipsel-broadcom-linux-uclibc

make
...
(MAKE="make"; srcdir=`cd /home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6/gcc/fixinc && ${PWDCMD-pwd}` ; \
        CC="gcc"; CFLAGS=" -DUSE_UCLIBC -g -O2 -DIN_GCC -DCROSS_COMPILE  -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-p
rototypes -pedantic -Wno-long-long  -Wno-error  -DHAVE_CONFIG_H -DGENERATOR_FILE"; LDFLAGS=""; \
        WARN_CFLAGS="-W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long  -Wno-error"; LIBERTY=`${PWDCMD-pwd}`/"../libiberty/libiberty.a"; \
        export MAKE srcdir CC CFLAGS LDFLAGS WARN_CFLAGS LIBERTY; \
        cd ./fixinc && \
        /bin/bash ${srcdir}/mkfixinc.sh i486-pc-linux-gnu mipsel-unknown-linux-uclibc)
constructing ../fixinc.sh for mipsel-unknown-linux-uclibc to run on i486-pc-linux-gnu
make TARGETS=oneprocess SHELL="/usr/bin/env bash -c '. /home/cin/kwork/kamikaze/include/shell.sh; eval "$2"' --" CC="gcc" CFLAGS=" -DUSE_UCLIBC -g -O2 -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -Wno-error -DHAVE_CONFIG_H -DGENERATOR_FILE" LDFLAGS="" LIBERTY="/home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6-final/gcc/../libiberty/libiberty.a" install-bin
make[6]: Entering directory `/home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6-final/gcc/fixinc'
/usr/bin/env bash -c '. /home/cin/kwork/kamikaze/include/shell.sh; eval mipsel-unknown-linux-uclibc' -- /home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6/gcc/fixinc/genfixes machname.h
--: mipsel-unknown-linux-uclibc: command not found
make[6]: *** [machname.h] Error 127
make[6]: Leaving directory `/home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6-final/gcc/fixinc'
make[5]: *** [fixinc.sh] Error 2
make[5]: Leaving directory `/home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6-final/gcc'
make[4]: *** [all-gcc] Error 2
make[4]: Leaving directory `/home/cin/kwork/kamikaze/build_dir/toolchain-mipsel/gcc-3.4.6-final'
make[3]: *** [/home/cin/kwork/kamikaze/staging_dir/toolchain-mipsel_gcc3.4.6/stamp/.gcc_installed] Error 2
make[3]: Leaving directory `/home/cin/kwork/kamikaze/toolchain/gcc'
make[2]: *** [toolchain/gcc/install] Error 2
make[2]: Leaving directory `/home/cin/kwork/kamikaze'
make[1]: *** [/home/cin/kwork/kamikaze/staging_dir/mipsel/stampfiles/.toolchain_install] Error 2
make[1]: Leaving directory `/home/cin/kwork/kamikaze'
make: *** [world] Error 2
INFO: Fix configuration files for WL-500W
cp: cannot stat `build_mipsel/root': No such file or directory
./buildWL500W.sh: 221: cannot create /tmp/root/etc/config/network: Directory nonexistent
md5sum: /tmp/root/etc/config/network: No such file or directory
ERROR: FATAL error wrong checksum on a file /tmp/root/etc/config/network

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by cinober

Sorry. Just ignore this ticket!
Duplicate of #2190 dev svn tree do not build

comment:2 Changed 9 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.