Modify

Opened 9 years ago

Closed 8 years ago

Last modified 22 months ago

#2404 closed defect (fixed)

No DHCP on Chillispot using 2.6 kernel version

Reported by: ggp81 Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: kernel 2.6 chillispot dhcp kamikaze 7.07 ap hotspot access point Cc:

Description

I tried Chillispot on a brcm-2.4 kernel, and I had not issues dealing with DHCP address assegnation.

However, with the same firewall rules and with the same *TESTED AND WORKING* chilli.conf, I wasn't able to get a DHCP address from an associated device using an Atheros-2.6-based firmware.

I disabled udhcpd and dnsmasq to avoid conflicts, and I removed any bridge from the interfaces. My dhcpif device is ath0 (wifi).
My configuration file follows:

net 10.101.101.0/24
dns1 xxx.xxx.xxx.xxx
dns2 xxx.xxx.xxx.xxx
domain xxxxx.it
radiusserver1 10.20.20.2
radiusserver2 10.20.20.2
radiusauthport 1812
radiusacctport 1813
radiusnasid xxxxx
radiuslocationid isocc=it,cc=0039,ac=0039,network=ACMEWISP_NewarkAirport
radiuslocationname ACMEWISP,Gate_14_Terminal_C_of_Newark_Airport
radiussecret xxxxx
dhcpif ath0
uamserver https://10.20.20.2/web_location/login
uamallowed www.xxxxx.it

Is that a kernel issue?

Attachments (0)

Change History (11)

comment:1 Changed 9 years ago by ggp81

Chillispot DHCP also works on adm5120-2.6 on r8177 pre-7.07 (just tested), so it sounds to be an Atheros-2.6 issue and not a generic-2.6 issue

comment:2 Changed 9 years ago by nbd

please show me your network/wifi config

comment:3 Changed 9 years ago by ggp81

/etc/config/network

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface lan
        option ifname   eth0
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0
        option dns      'xx.xx.xx.xx xx.xx.xx.xx' # they work

/etc/config/wireless

config wifi-device  wifi0
        option type     atheros
        option channel  '0'
#       option diversity 1
#       option txantenna 0
#       option rxantenna 0
#       option distance 2000
# disable radio to prevent an open ap after reflashing:
#       option disabled 0
        option mode     ''
        option maxassoc ''
        option distance ''
        option diversity        '1'
        option txantenna        '0'
        option rxantenna        '0'
        option disabled '0'

config wifi-iface
        option device   wifi0
        option mode     'ap'
        option ssid     'OpenWrt'
        option hidden   '0'
        option encryption       'none'
        option network  'none'
        option bssid    ''
        option server   ''
        option port     ''
        option isolate  '0'
        option txpower  '10'
        option bgscan   '1'
        option key1     ''
        option key2     ''
        option key3     ''
        option key4     ''

Thanks

comment:4 Changed 9 years ago by nbd

try setting the channel to something fixed

comment:5 Changed 9 years ago by ggp81

set:

        option channel  5

but nothing to do

comment:6 Changed 9 years ago by ggp81

Copying http://nbd.name/001-endian_fix.patch to package/chillispot/patches/ the problem is fixed. You should close the ticket and update the Chillispot package :)

comment:7 Changed 9 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [9041]

comment:8 follow-up: Changed 9 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

on my system running a IXP4xx 2.6 - Kernel the problem still exists.

comment:9 in reply to: ↑ 8 Changed 8 years ago by anonymous

Replying to anonymous:

on my system running a IXP4xx 2.6 - Kernel the problem still exists.

Sorry this was a problem of our boards. They start with no mac-address set
( 00:00:00:00:00:00 ) on the ether-interfaces. Setting the mac-addresses at initial script, solves this problem

comment:10 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.