Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#2522 closed enhancement (invalid)

busybox ping patch for selecting interface

Reported by: Bob Keyes Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: ping Cc:


It's useful to be able to select which interface a ping will go out over. This is most useful for when you have multiple upstreams, on of which is preferred. Say for instance, you have your own cable modem but have arranged with your neighbor to use his DSL modem in case you have a problem with your cable modem. It's easy enough to know when your modem is broken, and to change the default route to be your interface to your neighbor's cable modem. The problem is knowing when to switch back, without temporarily changing the default route back to your cable modem and trying it. With this patch, you can ping out to some central location on the Internet every so often over your cable modem, while the rest of your traffic flows over your neighbor's dsl modem. When your ping finally gets responses, you can switch the default route back over to your cable modem.

the usage will be
ping -n eth1
where eth1 is the interface you want to ping over and is the destination.

Patch is attached.

Attachments (1)

150-ping_select_device.patch (1.9 KB) - added by Bob Keyes 9 years ago.
busybox ping patch for interface selection

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Bob Keyes

busybox ping patch for interface selection

comment:1 Changed 9 years ago by thepeople

  • Resolution set to invalid
  • Status changed from new to closed

ping has a -I option for interfaces in trunk

comment:2 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.