Modify

Opened 9 years ago

Closed 8 years ago

#2645 closed defect (duplicate)

OHCI driver fails to initialize on BCM5354

Reported by: sbrown Owned by: florian
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Attached is a set of console output, one from a BCM5354 that fails and another from a BCM5352 that succeeds.

Also, there's a code snippet from Asus' WL520gu (5354-based) source release that seems to discuss the issue of initializing the OHCI/EHCI in the 5354 usb core. The snippet is from src/linux/linux/arch/mips/brcm-boards/bcm947xx/pcibios.c

If anybody recognizes the registers from the snippet and can explain what's going on, I can probably cook up a patch and test it.

Thanks,
Steve

Attachments (8)

ohci-bug.txt (1.2 KB) - added by sbrown 9 years ago.
Console output of failure
wl520gu-usb2-enable.c (2.1 KB) - added by sbrown 9 years ago.
code snippet
ohci.patch (1.8 KB) - added by sbrown 9 years ago.
Patch - 5354 OHCI driver now initializes
sbpci_init_regions.c (1.9 KB) - added by sbrown 9 years ago.
sb_corepciid.c (338 bytes) - added by sbrown 9 years ago.
USB20H dependency
230-ohci-ssb.patch (8.4 KB) - added by sbrown 9 years ago.
Enable ssb ohci driver from linux-mips
240-ohci-ssb-pm.patch (1.1 KB) - added by sbrown 9 years ago.
Correction for ssb ohci from linux-mips
250-ohci-ssb-usb2.patch (2.3 KB) - added by sbrown 9 years ago.
Enable bcm5354 ohci core from wl520gu & dd-wrt gpl code

Download all attachments as: .zip

Change History (16)

Changed 9 years ago by sbrown

Console output of failure

Changed 9 years ago by sbrown

code snippet

Changed 9 years ago by sbrown

Patch - 5354 OHCI driver now initializes

comment:1 Changed 9 years ago by sbrown

OHCI driver now initializes using ohci.patch, but disk drive gives error noted below.
=========================================================
ohci_hcd ssb0:1: SSB OHCI Controller
ohci_hcd ssb0:1: new USB bus registered, assigned bus number 1
ohci_hcd ssb0:1: irq 5, io mem 0x18003000
usb usb1: Product: SSB OHCI Controller
usb usb1: Manufacturer: Linux 2.6.23.1 ssb-usb-ohci
usb usb1: SerialNumber: ssb0:1
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
================================================
usb 1-1: new full speed USB device using ohci_hcd and address 3
usb 1-1: device descriptor read/64, error -62

Steve

comment:2 Changed 9 years ago by anonymous

oops, forgot formatting.

OHCI driver now initializes using ohci.patch, but plugging in disk drive gives error noted below.

=========================================================
ohci_hcd ssb0:1: SSB OHCI Controller
ohci_hcd ssb0:1: new USB bus registered, assigned bus number 1
ohci_hcd ssb0:1: irq 5, io mem 0x18003000
usb usb1: Product: SSB OHCI Controller
usb usb1: Manufacturer: Linux 2.6.23.1 ssb-usb-ohci
usb usb1: SerialNumber: ssb0:1
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
================================================
usb 1-1: new full speed USB device using ohci_hcd and address 3 
usb 1-1: device descriptor read/64, error -62

Steve

comment:3 Changed 9 years ago by sbrown

Problem is timeout from 1st get descriptor from the attached device.

Probably still don't have the USB20H core properly initialized.

Attached are two more code fragments that have USB20H dependencies.

sbpci_init_regions.c
sb_corepciid.c

Again, if anybody can explain what's going on here and how to incorporate these, let me know,

Thanks,
Steve

FWIW: The Asus WL-520gu only comes w/ code for the OHCI part of the core, but the ads say 2.0. Should I be surprised?

Changed 9 years ago by sbrown

Changed 9 years ago by sbrown

USB20H dependency

comment:4 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:5 Changed 9 years ago by sbrown

Attached are 3 patches needed to enable the ssb ohci driver.

230-ohci-ssb.patch 
240-ohci-ssb-pm.patch
250-ohci-ssb-usb2.patch

They go in target/linux/brcm47xx/patches-2.6.23/

Steve

Changed 9 years ago by sbrown

Enable ssb ohci driver from linux-mips

Changed 9 years ago by sbrown

Correction for ssb ohci from linux-mips

Changed 9 years ago by sbrown

Enable bcm5354 ohci core from wl520gu & dd-wrt gpl code

comment:6 Changed 9 years ago by sbrown

After discussing this on the linux-mips list, it probably makes more sense to follow up on the linux-usb list.

I've enabled dev_dbg & usbmon and will post those to that list.

If I can get this fixed, I'll post the patches. The author of ohci-ssb never had the hardware to actually test the driver other than to verify that insmod worked.

It's probably best to close this and I'll file a new report if I get the problem fixed.

Steve

comment:7 Changed 9 years ago by sbrown

Fixed w/ patch reported in 2757.

Steve

comment:8 Changed 8 years ago by florian

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #2757

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.