Opened 9 years ago

Closed 9 years ago

#2656 closed defect (fixed)

root shell prompt is '$' rather than '#'

Reported by: b.candler@… Owned by: developers
Priority: normal Milestone:
Component: base system Version:
Keywords: Cc:


Just built Kamikaze x86 from trunk (r9504), and I see the root shell prompt has changed from '#' to '$'. The following output is from running bin/openwrt-x86-2.6-ext2.image under qemu:

BusyBox v1.7.2 (2007-11-05 16:39:08 GMT) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (bleeding edge, r9504) -------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
root@OpenWrt:/$ id
uid=0(root) gid=0(root)
root@OpenWrt:/$ echo $PS1

I can't see why this is - as you can see PS1 is fine, and I have checked in make menuconfig, Busybox Configuration -> Shells, Ash -> [*] Expand prompt string is set.

This isn't entirely cosmetic, as existing management systems which telnet or ssh into the device may expect to see '...#' as the prompt.

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [9524]

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.