Modify

Opened 8 years ago

Closed 8 years ago

Last modified 22 months ago

#2727 closed defect (worksforme)

autossh , open-ssh client -server , sftp-client -server cant be compiled ( error 2)

Reported by: telstar924@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

Here is the log for sftp-server

rm -rf /mnt/sda1/trunk/build_dir/i386/openssh-4.7p1/ipkg-install
mkdir -p /mnt/sda1/trunk/build_dir/i386/openssh-4.7p1/ipkg-install
make -C /mnt/sda1/trunk/build_dir/i386/openssh-4.7p1 DESTDIR="/mnt/sda1/trunk/build_dir/i386/openssh-4.7p1/ipkg-install" LIBS="" sftp-server
make[4]: Entering directory `/mnt/sda1/trunk/build_dir/i386/openssh-4.7p1'
(cd openbsd-compat && make)
make[5]: Entering directory `/mnt/sda1/trunk/build_dir/i386/openssh-4.7p1/openbsd-compat'
i386-linux-uclibc-gcc -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -Wall -Wpointer-arith -Wuninitialized -Wsign-compare -Wno-pointer-sign -std=gnu99 -I. -I.. -I. -I./.. -I/mnt/sda1/trunk/staging_dir/i386/usr/include -DHAVE_CONFIG_H -c port-tun.c
port-tun.c: In function 'sys_tun_open':
port-tun.c:59: error: storage size of 'ifr' isn't known
port-tun.c:59: warning: unused variable 'ifr'
make[5]: * [port-tun.o] Error 1
make[5]: Leaving directory `/mnt/sda1/trunk/build_dir/i386/openssh-4.7p1/openbsd-compat'
make[4]:
* [openbsd-compat/libopenbsd-compat.a] Error 2
make[4]: Leaving directory `/mnt/sda1/trunk/build_dir/i386/openssh-4.7p1'
make[3]: * mnt/sda1/trunk/build_dir/i386/openssh-4.7p1/.built Error 2
make[3]: Leaving directory `/mnt/sda1/trunk/feeds/https_svn.openwrt.org_openwrt_packages_/net/openssh'
make[2]:
* [package/net/openssh/compile] Error 2
make[2]: Leaving directory `/mnt/sda1/trunk'
make[1]: * mnt/sda1/trunk/staging_dir/i386/stamp/.package_compile Error 2
make[1]: Leaving directory `/mnt/sda1/trunk'
make:
* [world] Error 2

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce the bug here, can you try again please ?

comment:2 Changed 8 years ago by telstar924@…

I tried again ,making a totally fresh installation from the trunk, it worked , ty

comment:3 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.