Modify

Opened 8 years ago

Closed 6 years ago

Last modified 21 months ago

#2767 closed defect (obsolete)

FreeBSD sed problem

Reported by: Bob Keyes Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: FreeBSD sed Cc:

Description

When trying to build OpenWRT on FreeBSD, building the toolchain gcc fails. This is because sed is called with the -E option, which does not exist in gnu sed but does exist in bsd sed. Unfortunately, the gnu version of sed is first in the path so it gets the call. See http://groups.google.com/group/mailing.freebsd.ports/msg/b1833c8019d87c02 for the FreeBSD bug report, but while they fix it in FreeBSD we should fix it in OpenWRT as well, perhaps by testing which version of sed we're using and making the appropriate calls.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by rtz2

  • Resolution set to obsolete
  • Status changed from new to closed
  • Version set to Trunk

OpenWrt builds it's own version of sed, which should come first in the PATH.
As nobody else complained about it, this is most likely obsolete.

comment:2 Changed 21 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.