Modify

Opened 8 years ago

Closed 8 years ago

#2866 closed defect (worksforme)

Bind: on x86 target, named is linked against host libnsl library

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: bind Cc:

Description

when builded in the image (not as a separate ipkg), named is linked against host libnsl library.

root@(none):/# ldd /usr/sbin/named
	liblwres.so.30 => /usr/lib/liblwres.so.30 (0xb7fb3000)
	libdns.so.32 => /usr/lib/libdns.so.32 (0xb7e9c000)
	libbind9.so.30 => /usr/lib/libbind9.so.30 (0xb7e93000)
	libisccfg.so.30 => /usr/lib/libisccfg.so.30 (0xb7e81000)
	libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb7d97000)
	libisccc.so.30 => /usr/lib/libisccc.so.30 (0xb7d90000)
	libisc.so.32 => /usr/lib/libisc.so.32 (0xb7d54000)
	libnsl.so.0 => /lib/libnsl.so.0 (0xb7d52000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7d49000)
	libc.so.0 => /lib/libc.so.0 (0xb7cfb000)
	libnsl.so.1 => not found
	libc.so.6 => not found
	libnsl.so.1 => not found
	libc.so.6 => not found
	libnsl.so.1 => not found
	libc.so.6 => not found
	libdl.so.0 => /lib/libdl.so.0 (0xb7cf8000)
	libnsl.so.1 => not found
	libc.so.6 => not found
	ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0xb7fc6000)

root@OpenWrt:/# ls /lib/libnsl*
/lib/libnsl-0.9.28.so  /lib/libnsl.so.0

libnsl.so.1 is the host library, the target library is libnsl.so.0

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

can't reproduce with current

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.