Modify

Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#3024 closed defect (invalid)

[package] 'nrpe' fails to build

Reported by: moh_de Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

I'n unable to build the packacke 'nrpe' in Kamikaze r10180.
The following error occurs:

make[3]: Leaving directory `/data/oni/additional-packages/net/nocatsplash'
make[3]: Entering directory `/data/oni/additional-packages/net/nodogsplash'
make[3]: Leaving directory `/data/oni/additional-packages/net/nodogsplash'
make[3]: Entering directory `/data/oni/additional-packages/net/nprobe'
make[3]: Leaving directory `/data/oni/additional-packages/net/nprobe'
make[3]: Entering directory `/data/oni/additional-packages/net/nrpe'
install -d -m0755 /data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/ipkg/nrpe/usr/sbin
install -d -m0755 /data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/ipkg/nrpe/etc
install -d -m0755 /data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/ipkg/nrpe/etc/init.d
install -m0644 ./files/nrpe.cfg /data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/ipkg/nrpe/etc/nrpe.cfg
install -m0755 /data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/nrpe /data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/ipkg/nrpe/usr/sbin
install: cannot stat `/data/oni/kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/nrpe': No such file or directory
make[3]: * data/oni/kamikaze-trunk/bin/packages//nrpe_2.8.1-1_mipsel.ipk Error 1
make[3]: Leaving directory `/data/oni/additional-packages/net/nrpe'
make[2]:
* [package/nrpe/compile] Error 2
make[2]: Leaving directory `/data/oni/kamikaze-trunk'
make[1]: * data/oni/kamikaze-trunk/staging_dir/mipsel/stamp/.package_compile Error 2
make[1]: Leaving directory `/data/oni/kamikaze-trunk'
make:
* [world] Error 2

A 'ls -l ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1//*' shows the following:

-rw-r--r-- 1 moh moh 3351 2002-02-22 02:15 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/contrib/nrpe_check_control.c
-rw-r--r-- 1 moh moh 1789 2003-10-24 03:00 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/contrib/README.nrpe_check_control
-rw-r--r-- 1 moh moh 2399 2007-05-10 16:34 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/include/common.h
-rw-r--r-- 1 moh moh 4741 2008-01-13 13:25 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/include/config.h
-rw-r--r-- 1 moh moh 4534 2006-12-12 03:03 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/include/config.h.in
-rw-r--r-- 1 moh moh 0 2008-01-13 13:25 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/include/dh.h
-rw-r--r-- 1 moh moh 2055 2006-12-12 03:04 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/include/nrpe.h
-rw-r--r-- 1 moh moh 1693 2006-12-12 03:04 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/include/utils.h
-rw------- 1 moh moh 6949 2008-01-13 13:25 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/sample-config/nrpe.cfg
-rw-r--r-- 1 moh moh 7003 2007-03-09 19:08 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/sample-config/nrpe.cfg.in
-rw------- 1 moh moh 432 2008-01-13 13:25 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/sample-config/nrpe.xinetd
-rw-r--r-- 1 moh moh 458 2007-03-09 20:19 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/sample-config/nrpe.xinetd.in
-rw-r--r-- 1 moh moh 12139 2007-05-10 16:34 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/check_nrpe.c
-rw-r--r-- 1 moh moh 1738 2008-01-13 13:25 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/Makefile
-rw-r--r-- 1 moh moh 1412 2007-05-10 16:34 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/Makefile.in
-rw-r--r-- 1 moh moh 46542 2007-05-10 16:34 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/nrpe.c
-rw-r--r-- 1 moh moh 10308 2006-12-12 03:04 ./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/src/utils.c

./kamikaze-trunk/build_dir/mipsel/nrpe-2.8.1/ipkg/nrpe:
total 12
drwxr-xr-x 2 moh moh 4096 2008-01-13 13:26 CONTROL
drwxr-xr-x 3 moh moh 4096 2008-01-13 15:59 etc
drwxr-xr-x 3 moh moh 4096 2008-01-13 13:26 usr

I also attached this info as textfile.

Attachments (1)

build_bug2.txt (3.2 KB) - added by moh_de 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by moh_de

comment:1 Changed 8 years ago by moh_de

A full clean and rebuild seemed to fix this issue, maybe I messed something up or there were some build artifacts left. Sorry.

I think this ticket can be closed - works as intended. Thank you.

comment:2 Changed 8 years ago by juhosg

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.