Modify

Opened 9 years ago

Closed 9 years ago

#3111 closed defect (invalid)

Access denied on dnsmask - Static dhcp not working.

Reported by: anonymous Owned by: developers
Priority: highest Milestone:
Component: packages Version:
Keywords: Cc:

Description

I have downloaded the x-wrt/open wrt package from x-wrt who contains open-wrt white russian 0.9. The dhcp server don't assign correctly my static ip adresses, I suppose it is caused by the following access denied.

Feb 5 12:46:38 OpenWrt kern.info dnsmasq[11424]: DHCPRELEASE(br0) 192.168.100.133 00:1d:09:1c:dd:83
Feb 5 12:46:25 OpenWrt kern.err dnsmasq[11424]: failed to read /etc/ethers:Permission denied
Feb 5 12:46:25 OpenWrt kern.err dnsmasq[11424]: failed to load names from /etc/hosts: Permission denied
Feb 5 12:45:53 OpenWrt kern.info dnsmasq[11424]: DHCPACK(br0) 192.168.100.133 00:1d:09:1c:dd:83 Steve

I am trying openwrt, checking if it is better than dd-wrt. I have absolutely no problems with dd-wrt except an intermitent upnp issue. Many of my pcs rely on static dhcp so it is an urgent matter. If not taken care rapidly, I will have to switch back to dd-wrt and maybe come back later.

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Luboš Staněk <lubek@…>

The White Russian branch is not developed anymore.

The X-Wrt repository is quite different from the OpenWrt repository for White Russian. There are many updated, fixed and new packages. If you want to use X-Wrt, report issues there. Thanks

There were packages with wrong permissions in the X-Wrt repository for some time.
If you installed some package with files in the /etc directory, it might get wrong permissions. try to fix it using these commands:

chmod 755 /etc
chmod 644 /etc/ethers /etc/hosts

This issue touches only dnsmasq because it runs under a different account.

comment:2 Changed 9 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.