Opened 11 years ago

Closed 10 years ago

Last modified 2 years ago

#318 closed defect (fixed)

netbooting kamikaze on wgt634u bricks them

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: 2.0
Keywords: wgt634u Cc:


the original thread is here:

at least 3 persons have bricked their wgt634u netbooting kamikaze in the last 2 months.
It seems i was the last one (using kamikaze rev 3217)

As I said, kamikaze was booted from cfe with latest orignal netgear firmware still on.
I think it could be something run from /bin/firstboot or /sbin/mount_root.
or maybe a bcm map or nvram kernel problem.
Can't tell for sure.

Let's see who's the first the reproduce it :)
(and who's the first to jtag reflash its wgt634u)

any way, thanks for your work !

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by olli

  • Milestone set to 2.0
  • Version set to 2.0

comment:2 Changed 11 years ago by dacb

I have been unable to reproduce this problem with 3535. I have tried loading the kernel from flash and doing NFS root as well as tftp loading the kernel and NFS root.

What I can tell you, is that it is possible to disable the MTD drivers (comment out CONFIG_MTD in the kernel config) so that nothing can write to your flash. With flash write disabled, it isn't going to be easy from something to clobber CFE (and thereby brick your device).

comment:3 Changed 11 years ago by anonymous

What the bug is about is netbooting with a original firmware still on flash.
there's a bug somewhere. it should not happen.

congrats for not being able to reproduce a bug that does exist in this context ! ;-)

if you want to help, flash the original firmware back on your wgt, and netboot a modified openwrt (yeah you have to some change to be able to netboot). then please try every init script (firstboot and co) by hand with sh -x or strace. between each command check cfe (with dd if=/dev/mtd/0ro |md5sum) and tell us what command trigger the bug.
keep the logs and stuff.

This would help !
anything else wont.

sorry if it doesn't sound nice, but thanks in advance !
as long as you don't crash your wgt with madwifi (for example) you should be able to rewrite your cfe.

Thanks again ! ;-)

comment:4 Changed 10 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in [4634]

comment:5 Changed 9 years ago by anonymous

had the same problem with kernel... but fixed it and it's ok.


comment:6 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.