Opened 9 years ago

Closed 8 years ago

#3189 closed defect (fixed)

ISC dhcp segfaults whn loaded during bootup

Reported by: daniel@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:


I get segfaults when dhcp starts during a reboot of my router. Once the router has booted up I can manually start dhcp and it works the way it should.

I run Kamikaze 7.09 on a Wrt54GS. I have the following version of dhcp installed:

Package: dhcp-server
Version: 3.0.6-1
MD5Sum: 09b7c1d026b0481c40e6dcbc9982200d
Filename: ./dhcp-server_3.0.6-1_mipsel.ipk
Source: /data/release/packages/packages/net/dhcp
Description: ISC's DHCP server

Here is my /etc/init.d/dhcp

#!/bin/sh /etc/rc.common


start() {	
	mkdir /var/state/dhcp
	touch /var/state/dhcp/dhcpd.leases
	route add -host dev br-lan

stop() {
	route del -host dev br-lan
	killall dhcpd

Here is my /etc/dhcpd.conf

# Sample /etc/dhcpd.conf
# (add your comments here) 

default-lease-time 6000;
max-lease-time 6000;
option subnet-mask;
option broadcast-address;
#option routers;
option domain-name-servers;
option domain-name "";

ddns-update-style ad-hoc; #Won't start without a line like this.

subnet netmask {

The only output I get to the log is the following line:

Mar  1 14:04:42 maple : Segmentation fault

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by opwnrt@…

i can't get the ISC-DHCPD to start on boot either. i do not have a serial cable attached so i don't know if it seg faults. all i know it it will not run on boot.

once its booted the daemon starts fine with /etc/init.d/dhcpd start.

any help on this would be great because its a pain to have to login and start the dhcp.


comment:2 Changed 8 years ago by anonymous

I encounter exactly the same problem on the same router with the same dhcpd's version.

This problem is really boring

dhcp crash very oftenly !

i think i will try dd-wrt ...

comment:3 Changed 8 years ago by anonymous

hey ! problem solved with kamikaze 8.09 RC1 (dhcpd v3.1.0)

and wifi was very unstable and unusable with 7.09 ...working nicely with kamikaze 8.09 bcm47xx (kernel 2.6)

thank you very much for this new release !! waiting for final version ...

comment:4 Changed 8 years ago by agb

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.