Modify

Opened 8 years ago

Closed 8 years ago

Last modified 21 months ago

#3221 closed defect (duplicate)

madwifi in crash in r10555, r10519 works okay.

Reported by: lorenz.schori@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

This is a two-interface setup on x86. Madwifi crashes during "iwpriv ath0 mode 11g". Got the following information from dmesg:

wlan: trunk
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.30.13 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5
413, RF2133)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
wlan: mac acl policy registered
ath_pci: trunk
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 3
6Mbps 48Mbps 54Mbps
wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi0: Atheros 5212: mem=0xe0040000, irq=9
wifi1: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi1: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 3
6Mbps 48Mbps 54Mbps
wifi1: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi1: Atheros 5212: mem=0xe0080000, irq=11
ne2k-pci.c:v1.03 9/22/2003 D. Becker/P. Gortmaker
pcnet32.c:v1.33-NAPI 27.Jun.2006 tsbogend@alpha.franken.de
via-rhine.c:v1.10-LK1.4.3 2007-03-06 Written by Donald Becker
PCI: Setting latency timer of device 0000:00:09.0 to 64
eth0: VIA Rhine III (Management Adapter) at 0xe0000000, 00:0d:b9:13:83:34, IRQ 
10.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link c5e1.
BUG: unable to handle kernel NULL pointer dereference at virtual address 000000
04
 printing eip:
d09a3188
*pde = 00000000
Oops: 0000 [#1]
SMP 
Modules linked in: via_rhine pcnet32 ne2k_pci 8390 ath_pci wlan_xauth wlan_wep 
wlan_tkip wlan_ccmp wlan_acl ath_rate_minstrel ath_hal(P) wlan_scan_sta wlan_sc
an_ap wlan leds_alix nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc 
nf_nat_ftp nf_conntrack_ftp ipt_REDIRECT ipt_NETMAP ipt_TOS ipt_TTL xt_MARK ipt
_ECN xt_CLASSIFY ipt_ttl ipt_tos ipt_time xt_tcpmss xt_statistic xt_mark xt_mac
 xt_length ipt_ecn xt_DSCP xt_dscp imq ipt_IMQ xt_string ipt_ipp2p xt_NOTRACK x
t_CONNMARK ipt_recent xt_helper xt_conntrack xt_connmark xt_connbytes sit tunne
l4 tun ppp_async ppp_generic slhc crc_ccitt natsemi ipv6
CPU:    0
EIP:    0060:[<d09a3188>]    Tainted: P        VLI
EFLAGS: 00010046   (2.6.23.16 #1)
EIP is at zz0b69b07c+0x60/0xb0 [ath_hal]
eax: 00000000   ebx: c12a0000   ecx: cfa49dc6   edx: 00000000
esi: c12a0000   edi: 00000000   ebp: c12a0000   esp: cfa49db0
ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Process ifconfig (pid: 783, ti=cfa48000 task=c12c3030 task.ti=cfa48000)
Stack: c12a0000 00000000 c12a0000 d09a3ba1 c12a0000 00000000 c12a0000 00000000 
       c12a0000 d099ea2e c12a0000 00000000 00000001 cfe22b7c b7f23f07 00000246 
       c01b22e8 00000000 c124a320 00000000 c0162319 00000000 cfa49f04 c015865c 
Call Trace:
 [<d09a3ba1>] zz0016d872+0x15/0x1e4 [ath_hal]
 [<d099ea2e>] zz0002dbd2+0xe6/0xd24 [ath_hal]
 [<c01b22e8>] __up_read+0xf/0x76
 [<c0162319>] mntput_no_expire+0x11/0x5f
 [<c015865c>] __link_path_walk+0x96f/0xb0f
 [<d0974975>] ath_hw_reset+0x3c/0x7c [ath_pci]
 [<d0975238>] ath_init+0x1c5/0x3a1 [ath_pci]
 [<c0221949>] dev_open+0x2e/0x68
 [<d0937918>] ieee80211_init+0x3b/0xc1 [wlan]
 [<c0221949>] dev_open+0x2e/0x68
 [<c021fb6f>] dev_change_flags+0x9c/0x14f
 [<c0260565>] devinet_ioctl+0x226/0x54f
 [<c022187b>] dev_ioctl+0x3c1/0x401
 [<c0221949>] dev_open+0x2e/0x68
 [<d0937918>] ieee80211_init+0x3b/0xc1 [wlan]
 [<c0221949>] dev_open+0x2e/0x68
 [<c021fb6f>] dev_change_flags+0x9c/0x14f
 [<c0260565>] devinet_ioctl+0x226/0x54f
 [<c022187b>] dev_ioctl+0x3c1/0x401
 [<c0218527>] sock_ioctl+0x16d/0x192
 [<c02183ba>] sock_ioctl+0x0/0x192
 [<c015a4ef>] do_ioctl+0x1f/0x63
 [<c02177c3>] sys_socket+0x29/0x3e
 [<c015a783>] vfs_ioctl+0x250/0x26a
 [<c015a7d0>] sys_ioctl+0x33/0x4b
 [<c0104256>] syscall_call+0x7/0xb
 [<c0270000>] unix_bind+0xb9/0x271
 =======================
Code: 00 00 00 00 83 c4 18 5b c3 89 f6 57 56 53 8b 7c 24 14 8b 74 24 10 ba 00 0
0 00 00 8d 04 52 c1 e0 03 29 d0 66 8b 84 86 2c 2f 00 00 <66> 3b 47 04 75 06 89 
d0 eb 41 89 f6 8d 04 52 c1 e0 03 29 d0 8d 
EIP: [<d09a3188>] zz0b69b07c+0x60/0xb0 [ath_hal] SS:ESP 0068:cfa49db0
Clocksource tsc unstable (delta = 659975280 ns)
Time: pit clocksource has been installed.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by acoul <alex@…>

there is a relative ticket for this issue already opened here: #3213

comment:2 Changed 8 years ago by agb

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #3213, as noted.

comment:3 Changed 21 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.