Modify

Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#3244 closed defect (duplicate)

madwifi on x86 10610

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version:
Keywords: Cc:

Description

BUG: unable to handle kernel NULL pointer dereference at virtual address 00000004
printing eip: c8923188 *pde = 00000000
Oops: 0000 #1 SMP
Modules linked in: via_rhine ne2k_pci 8390 ath_pci wlan_xauth wlan_wep wlan_tkip wlan_ccmp i

Pid: 675, comm: ifconfig Tainted: P (2.6.24.2 #1)
EIP: 0060:[<c8923188>] EFLAGS: 00010046 CPU: 0
EIP is at zz0b69b07c+0x60/0xb0 [ath_hal]
EAX: 00000000 EBX: c7c98000 ECX: c718bdc2 EDX: 00000000
ESI: c7c98000 EDI: 00000000 EBP: c7c98000 ESP: c718bdac

DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068

Process ifconfig (pid: 675, ti=c718a000 task=c7ee7580 task.ti=c718a000)
Stack: c7c98000 00000000 c7c98000 c8923ba1 c7c98000 00000000 c7c98000 00000000

c7c98000 c891ea2e c7c98000 00000000 00000001 00000000 47dfa731 b7f6cf07
c704e518 c7006060 c0193988 c7c0cea0 00000000 c0163f19 c0193988 c718bf04

Call Trace:

[<c8923ba1>] zz0016d872+0x15/0x1e4 [ath_hal]
[<c891ea2e>] zz0002dbd2+0xe6/0xd24 [ath_hal]
[<c0193988>] mini_fo_put_link+0x0/0xc
[<c0163f19>] mntput_no_expire+0x11/0x5f
[<c0193988>] mini_fo_put_link+0x0/0xc
[<c015a206>] link_path_walk+0x96f/0xb0f
[<c88f39d6>] ath_suspend+0x41/0xae0 [ath_pci]
[<c88f4299>] ath_suspend+0x904/0xae0 [ath_pci]
[<c0224e46>] dev_open+0x42/0x77
[<c88bd918>] ieee80211_init+0x3b/0xdc [wlan]
[<c0224e46>] dev_open+0x42/0x77
[<c0223ba8>] dev_change_flags+0x9c/0x14a
[<c0222a1b>]
dev_get_by_name+0x68/0x73
[<c0263a94>] devinet_ioctl+0x22b/0x554
[<c014340a>] do_fault+0x2b8/0x2f3
[<c021b457>] sock_ioctl+0x17f/0x1a8
[<c021b2d8>] sock_ioctl+0x0/0x1a8
[<c015c0fb>] do_ioctl+0x1f/0x63
[<c011250f>] do_page_fault+0x195/0x562
[<c015c38f>] vfs_ioctl+0x250/0x26a
[<c015c3dc>] sys_ioctl+0x33/0x4b
[<c0104282>] syscall_call+0x7/0xb
[<c0280000>]
down_failed+0x8/0xc
=======================

Code: 00 00 00 00 83 c4 18 5b c3 89 f6 57 56 53 8b 7c 24 14 8b 74 24 10 ba 00 00 00 00 8d 0
EIP: [<c8923188>] zz0b69b07c+0x60/0xb0 [ath_hal] SS:ESP 0068:c718bdac
---[ end trace c53c019ba5b762ea ]---
Clocksource tsc unstable (delta = 640029589 ns)
Time: pit clocksource has been installed.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Davide Guerri <d.guerri@…>

It's a duplicate of #3213 ...

comment:2 Changed 8 years ago by agb

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.