Modify

Opened 8 years ago

Closed 8 years ago

#3255 closed defect (worksforme)

Segmentations faults/Bus Errors with OpenWRT+Debian on wl500gP after 32MB trick

Reported by: Orlik - cfanygapa@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: wl500gp Debian segmentation fault bus error Cc:

Description

I'm using OpenWRT custom kernel to boot Debian from USB (stick/2.5" disk) on wl500gP as described in nice project under http://wpkg.org/Running_Debian_on_ASUS_WL-500G_deluxe
If I'm running Debian with default 16MB of memory (sdram_init=0x000b)
everything work perfect.
If I only switch to 32MB (sdram_init=0x0009) lots of segmentation faults
and bus errors start to occur. So I cant boot my system with 32MB
because of that.
I've tried to compile many revisions (r5375 , r6850, r9442, r10517) but
problem still persists.
The funny thing is that regular (non-Debian) boot with fully flash ROM
based Kamikaze built (r10517) runs fine with 32MB enabled(!).

So I don't understand where the problem is. Kernel, nvram settings or Debian specific?
Other people run Debian with 32MB without similar problems, but I've
found their nvram's "hardware_version" value is WL500gp-01-02-00-00.
Mine is hardware_version=WL500gH-01-00-00-00. Can this be an issue? Do
I have some old trash? Do you have any suggestions? I think my problem is not connected with #2035.

I'm attaching an example serial log of failed boot with 32MB enabled

Thanks

PS: If you think it's not OpenWRT related because of Debian please close the ticket.

Attachments (1)

2.6.23.16_r10517_fail_boot.txt (13.4 KB) - added by Orlik - cfanygapa@… 8 years ago.
Failed boot serial console log

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Orlik - cfanygapa@…

Failed boot serial console log

comment:1 Changed 8 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

probably kernel specific, the newest kernel in openwrt should work much better than whatever was packaged for debian back then.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.