Modify

Opened 8 years ago

Closed 8 years ago

#3453 closed defect (worksforme)

ipkg might use wrong checksums to check packages' integrity

Reported by: KanjiMonster Owned by: developers
Priority: normal Milestone:
Component: base system Version:
Keywords: Cc:

Description

When trying to install a package from the local file system and any feed contains the package with the same file name, but different checksum, iPKG refuses to install the package and complains over a md5 mismatch.
This also happens if there *is* a feed with the correct checksum.

The only way to fix this is to disable the feed with the "wrong" checksum before installing, and reenabling it after it.

This can happen if one uses webif2 and uses trunk, as the snapshot-repository gets included in the ipkg sources list, and contains several packages of openwrt.

Ipkg should probably check if it matches any of the checksums of all feeds. Currently it seems it works the other way round (breaks if it does not match all checksums, or check only one feed and not all feeds).

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce with now used opkg.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.