Modify

Opened 8 years ago

Closed 8 years ago

#3496 closed defect (worksforme)

lzo doesn't install its development files into the staging area

Reported by: russell-openwrt@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: lzo openvpn Cc:

Description

I was trying to build openvpn, which apparently needs lzo. I added the lzo package, but after doing that the openvpn configure step failed because it could not find the development files. It turned out they were getting installed into packages/lzo/liblzo instead of the staging area.

A patch to fix the problem is attached.

Attachments (3)

lzo-install-dev.2.diff-Nur (730 bytes) - added by russell-openwrt@… 8 years ago.
Patch to install lzo development files in the correct directory
lzo-install-dev.diff-Nur (730 bytes) - added by russell-openwrt@… 8 years ago.
Patch to install lzo development files in the correct directory
make-lzo-v99-output.txt (3.7 KB) - added by russell-openwrt@… 7 years ago.
Output of hacked lzo/Makefile

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by russell-openwrt@…

Patch to install lzo development files in the correct directory

Changed 8 years ago by russell-openwrt@…

Patch to install lzo development files in the correct directory

comment:1 Changed 8 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

Make sur you did resolve the lzo dependency by putting it into package/ while building openvpn. Your patch does not do anything because $(1) is equal to $(STAGING_DIR) when called in the InstallDev template.

Changed 7 years ago by russell-openwrt@…

Output of hacked lzo/Makefile

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.