Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3523 closed defect (wontfix)

Command 'set mssid' failed: -1 on WRT54G corerev 7

Reported by: matthias@… Owned by: developers
Priority: high Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: Cc:

Description

The Multi-SSID feature does not work at all on WRT54G V2, V2.2 and V3.1. It does work on WRT54GL V1.1.

The difference is in the corerev. The broadcom driver does work as expected on corerev 9 (BCM5352), but not on corerev 7 (BCM4712).

I could verify the problem with an older Kamikaze branch, as well as with todays SVN (r11410). The problem is existent on dd-wrt v24 as well.

I would like to know if this is a software issue only with the binary broadcom-driver, or if the hardware is just not capable of doing Multi-SSID.

If it is a software issue: any chance to fix it?

The problem can be reproduced by configuring at least two interfaces in /etc/config/wireless and call wifi afterwards. Doing so results in the following error messages on corerev 7:

root@OpenWrt:/# wifi
Command 'set mssid' failed: -1
Command 'set enabled' failed: -1
root@OpenWrt:/# wl0.1: Operation not permitted

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 8 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

multi-ssid is only supported on corerev 9 and newer.
the unconditional use of mssid has been fixed in r12769

comment:2 in reply to: ↑ 1 Changed 7 years ago by tuzzer

Replying to nbd:

multi-ssid is only supported on corerev 9 and newer.

Why? It works fine with Kamikaze 7.09. Is this because of a newer Broadcom driver?

comment:3 follow-up: Changed 7 years ago by exelsus

so, in other words, is impossible for a wrt54g(s) to set WDS+AP, or STA+AP???????

comment:4 in reply to: ↑ 3 Changed 7 years ago by jow

Replying to exelsus:

so, in other words, is impossible for a wrt54g(s) to set WDS+AP, or STA+AP???????

If corerev is < 9, yes.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.