Modify

Opened 8 years ago

Closed 8 years ago

#3536 closed defect (worksforme)

Madwifi poor performance since ath_hal-20080528

Reported by: hugelshofer2006@… Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: madwifi poor performance hal Cc:

Description

I am using a WG302v2 (IXP4XX) with OpenWRT compiled from trunk (r11319). The wireless card operates in 802.11g and is set into ad-hoc mode. A workstation sends a single TCP stream generated with netperf to the router, which forwards it to another workstation (everything wireless).

Usually I get 12Mbps throughput but with r11319 I only get 4Mbps. Besides the slow throughput the driver is working fine. I was not able to exactly locate the change, which caused the throughput drop, because releases before r11319 (e.g. r11314 and earliers) failed to build. When I use kmod-madwifi built from r11184, then I get the usual good throughput. The measurements were performed just minutes apart.

I suspect the introduction of ath_hal-20080528 in r11314 to be causing the problems.

Messages from loading the madwifi drivers from r11319 at bootup:

wlan: trunk
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.10.5.6 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF54)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
wlan: mac acl policy registered
ath_pci: trunk                                                                  
PCI: enabling device 0000:00:01.0 (0340 -> 0342)
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 3s
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi0: Atheros 5212: mem=0x48000000, irq=25

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by hugelshofer2006@…

I was not able to reproduce again. Seems to have been a temporal interference problem. Please close...

comment:2 Changed 8 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.