Modify

Opened 8 years ago

Closed 8 years ago

Last modified 22 months ago

#3748 closed defect (duplicate)

[Packages] utils/dosfstools does not compile

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description (last modified by florian)

openwrt@debian:~/alix.2c2$ make package/dosfstools/{clean,compile} V=99
make[1]: Entering directory `/home/openwrt/alix.2c2'
make[2]: Entering directory `/home/openwrt/alix.2c2/feeds/packages/utils/dosfstools'
rm -f /home/openwrt/alix.2c2/staging_dir/i386/stamp/.dosfstools_installed
rm -f /home/openwrt/alix.2c2/bin/packages/i386/dosfstools_*
make[2]: Leaving directory `/home/openwrt/alix.2c2/feeds/packages/utils/dosfstools'
make[1]: Leaving directory `/home/openwrt/alix.2c2'
make[1]: Entering directory `/home/openwrt/alix.2c2'
make[2]: Entering directory `/home/openwrt/alix.2c2/feeds/packages/utils/dosfstools'
gzip -dc /home/openwrt/public_html/sources/dosfstools-2.11.src.tar.gz | /bin/tar -C /home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/.. -xf -

Applying ./patches/001-symbolic_links.patch using plaintext:
patching file dosfsck/Makefile
patching file mkdosfs/Makefile

Applying ./patches/002-linux_26_headers.patch using plaintext:
patching file dosfsck/common.h
patching file dosfsck/file.c
patching file dosfsck/io.c
patching file mkdosfs/mkdosfs.c
touch /home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/.prepared_03a9366601ac5c08282f5b83dd151bd4
touch /home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/.configured
make -C /home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11 AR=i386-linux-uclibc-ar AS="i386-linux-uclibc-gcc -c -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts" LD=i386-linux-uclibc-ld NM=i386-linux-uclibc-nm CC="i386-linux-uclibc-gcc" GCC="i386-linux-uclibc-gcc" CXX=i386-linux-uclibc-g++ RANLIB=i386-linux-uclibc-ranlib STRIP=i386-linux-uclibc-strip OBJCOPY=i386-linux-uclibc-objcopy OBJDUMP=i386-linux-uclibc-objdump SIZE=i386-linux-uclibc-size OPTFLAGS="-O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -D_FILE_OFFSET_BITS=64" PREFIX="/usr" SBINDIR="/usr/sbin" all
make[3]: Entering directory `/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11'
make -C mkdosfs all
make[4]: Entering directory `/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/mkdosfs'
i386-linux-uclibc-gcc -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -D_FILE_OFFSET_BITS=64 -Wall  -c mkdosfs.c -o mkdosfs.o
mkdosfs.c: In function 'setup_tables':
mkdosfs.c:806: warning: pointer targets in passing argument 1 of 'strncpy' differ in signedness
mkdosfs.c:808: warning: pointer targets in passing argument 1 of 'strcpy' differ in signedness
mkdosfs.c: In function 'main':
mkdosfs.c:1424: warning: 'cblocks' may be used uninitialized in this function
i386-linux-uclibc-gcc  mkdosfs.o -o mkdosfs
make[4]: Leaving directory `/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/mkdosfs'
make -C dosfsck all
make[4]: Entering directory `/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/dosfsck'
i386-linux-uclibc-gcc -c -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -D_FILE_OFFSET_BITS=64 -Wall  boot.c
In file included from /home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/little_endian.h:104,
                 from /home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/asm/byteorder.h:70,
                 from dosfsck.h:21,
                 from boot.c:13:
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:149: error: expected declaration specifiers or '...' before 'u16'
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: In function 'le16_add_cpu':
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:151: error: 'val' undeclared (first use in this function)
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:151: error: (Each undeclared identifier is reported only once
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:151: error: for each function it appears in.)
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: At top level:
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:154: error: expected declaration specifiers or '...' before 'u32'
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: In function 'le32_add_cpu':
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:156: error: 'val' undeclared (first use in this function)
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: At top level:
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:159: error: expected declaration specifiers or '...' before 'u64'
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: In function 'le64_add_cpu':
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:161: error: 'val' undeclared (first use in this function)
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: At top level:
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:164: error: expected declaration specifiers or '...' before 'u16'
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: In function 'be16_add_cpu':
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:166: error: 'val' undeclared (first use in this function)
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: At top level:
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:169: error: expected declaration specifiers or '...' before 'u32'
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: In function 'be32_add_cpu':
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:171: error: 'val' undeclared (first use in this function)
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: At top level:
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:174: error: expected declaration specifiers or '...' before 'u64'
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h: In function 'be64_add_cpu':
/home/openwrt/alix.2c2/staging_dir/toolchain-i386_gcc4.1.2/lib/gcc/i386-linux-uclibc/4.1.2/../../../../i386-linux-uclibc/sys-include/linux/byteorder/generic.h:176: error: 'val' undeclared (first use in this function)
boot.c: In function 'dump_boot':
boot.c:68: warning: pointer targets in passing argument 2 of 'strncpy' differ in signedness
make[4]: *** [boot.o] Error 1
make[4]: Leaving directory `/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/dosfsck'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11'
make[2]: *** [/home/openwrt/alix.2c2/build_dir/i386/dosfstools-2.11/.built] Error 2
make[2]: Leaving directory `/home/openwrt/alix.2c2/feeds/packages/utils/dosfstools'
make[1]: *** [package/feeds/packages/dosfstools/compile] Error 2
make[1]: Leaving directory `/home/openwrt/alix.2c2'
make: *** [package/dosfstools/compile] Error 2
openwrt@debian:~/alix.2c2$

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by anonymous

Dupe of #3452, please search before filing tickets.

comment:2 Changed 8 years ago by florian

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.