Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3755 closed defect (wontfix)

kmod-ebtables not built with kernel 2.6.25+

Reported by: basmevissen Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: ebtables kernel linux Cc: abuse@…

Description

The kmod-ebtables package isn't built with kernel 2.6.25+ because the ebtables kmods aren't built. Cause is a new Linux kernel dependancy since 2.6.25 requiring CONFIG_BRIDGE_NETFILTER=y defined for the ebtables kernel modules to be built.

Attached patch corrects this. Please apply.
Tested against trunk r11629.

Attachments (1)

k2.6.25-ebtables.patch (940 bytes) - added by basmevissen 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by basmevissen

comment:1 Changed 8 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

Enabling bridge filtering slows down the bridging between interfaces, which is the reason why we have disabled it. We are currently working on a solution to avoid setting CONFIG_NETFILTER_BRIDGE.

comment:2 Changed 8 years ago by basmevissen

Is interface bridging also significantly slowed down when the ebtables kernel modules are not loaded into the kernel?

comment:3 Changed 8 years ago by anonymous

Don't do that ! or at least, give an alternative, because IPv6 brouting is used for some configurations, actually i'm thinking of the "free" (free.fr) french isp that provides /64 ipv6 addresses, which cannot be used through a router/gateway without brouting.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.