Modify

Opened 8 years ago

Closed 8 years ago

Last modified 22 months ago

#3774 closed defect (duplicate)

wpa_supplicant config switch "Disable timestamp check" creates invalid .config-package.in file

Reported by: daniel@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

package/wpa_supplicant/Makefile:

[..]
define Package/wpa-supplicant/config
  config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
        bool "Disable timestamp check"
        depends PACKAGE_wpa-supplicant
        default n
        help
                This disables the timestamp check for certificates in wpa_supplicant
                Useful for devices without RTC that cannot reliably get the real date/time
endef
[..]

In the Networking section all packages after wpa_supplicant (e.g. wpa_cli) are swallowed by the "help" statement. You can confirm this by simply viewing the help during make menuconfig.

If you remove the "help" part everything works as expected:

define Package/wpa-supplicant/config
  config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
        bool "Disable timestamp check"
        depends PACKAGE_wpa-supplicant
        default n
endef

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by agb

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of [3773], fixed in [11850]

comment:2 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.