Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#3832 closed defect (duplicate)

ath9k should be part of the mac80211 package

Reported by: acoul <alex@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: ath5k mac80211 trunk Cc:


trying to compile ath9k on x86 trunk 12059 produces the following:

make[4]: Entering directory `/extra3/openwrt/x86/trunk/build_dir/linux-x86_generic/linux-'
  CC [M]  /extra3/openwrt/x86/trunk/build_dir/linux-x86_generic/ath9k-20080731/drivers/net/wireless/ath9k/rc.o
/extra3/openwrt/x86/trunk/build_dir/linux-x86_generic/ath9k-20080731/drivers/net/wireless/ath9k/rc.c:23:34: error: ../net/mac80211/rate.h: No such file or directory

it looks like latest ath9k depends on latest mac80211 stack and not the in-kernel one. perhaps ath9k should be included in the mac80211 package.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by acoul <alex@…>

apparently this is already the case. looking at the package/ath9k/Makefile:

LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211 -I$(LINUX_DIR)/include -include linux/autoconf.h" $(EXTRA_KCONFIG)

so the following patch is sufficient and fixes this issue:

diff -Nrub a/ath9k/src/drivers/net/wireless/ath9k/rc.c b/ath9k/src/drivers/net/wireless/ath9k/rc.c
--- a/ath9k/src/drivers/net/wireless/ath9k/rc.c 2008-08-01 10:52:38.000000000 +0300
+++ b/ath9k/src/drivers/net/wireless/ath9k/rc.c 2008-08-01 10:54:16.000000000 +0300
@@ -20,7 +20,7 @@

 #include "core.h"
-#include "../net/mac80211/rate.h"
+#include "rate.h"

 static u_int32_t    tx_triglevel_max;

comment:2 Changed 8 years ago by anonymous

works for me without any patches.. maybe you didn't enable mac80211?

comment:3 Changed 8 years ago by acoul <alex@…>

the above patch forces the use of the most fresh rate.h the system finds according to my understanding.

comment:4 Changed 8 years ago by acoul <alex at>

ath9k was included in wireless-testing as of yesterday.

comment:5 Changed 8 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3857

comment:6 Changed 8 years ago by florian

Duplicate of #3853 sorry.

comment:7 Changed 8 years ago by acoul <alex@…>

indeed, thanks.

comment:8 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.