Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3848 closed defect (worksforme)

target/linux/adm5120/Makefile missing ARCH, breaks menuconfig

Reported by: KanjiMonster Owned by: developers
Priority: high Milestone: Kamikaze 8.09 RC1
Component: toolchain Version:
Keywords: Cc:

Description

menuconfig does not work in trunk:

xxx@shaker:~/openwrt/trunk$ make menuconfig
tmp/.config-target.in:96: invalid option
make: *** [menuconfig] Error 1

Line 96 in .config-target.in is

92: config TARGET_adm5120
93:        bool "Infineon/ADMtek ADM5120 [2.6]"
94:        select LINUX_2_6
95:        select LINUX_2_6_25
96:        select
97:    

Which probably is because target/linux/adm5120/Makefile does not declare an ARCH (was removed in r11933, presumably by accident).

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the bug here.

comment:2 Changed 8 years ago by KanjiMonster

Just an addendum:
while clearing the tmp directory did not help (tried that earlier), deleting the tmp directory did the trick. Must have been some problem with updating and having old generated files.
(Just tried the latter).

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.