Opened 8 years ago

Closed 8 years ago

#3931 closed defect (fixed)

AR7 fails to build bridge-utils after r12346

Reported by: KillaB Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: base system Version:
Keywords: ar7 bridge-utils Cc: kaloz


I was successful in compiling r12345, but r12346 to current (r12384) fail on the following error:

make[3]: Entering directory `/home/OpenWrt/DG834G_12376/trunk/package/bridge-utils'
(cd /home/OpenWrt/DG834G_12376/trunk/build_dir/linux-ar7/bridge-utils-1.4; autoconf; ./configure --target=mipsel-linux --host=mipsel-linux --build=i486-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib --sysconfdir=/etc --datadir=/usr/share --localstatedir=/var --mandir=/usr/man --infodir=/usr/info --disable-nls --with-linux-headers="/home/OpenWrt/DG834G_12376/trunk/build_dir/linux-ar7/linux-"  )
autoconf: Undefined macros:
configure: error: can not find sources in . or ..
make[3]: *** [/home/OpenWrt/DG834G_12376/trunk/build_dir/linux-ar7/bridge-utils-1.4/.configured] Error 1
make[3]: Leaving directory `/home/OpenWrt/DG834G_12376/trunk/package/bridge-utils'
make[2]: *** [package/bridge-utils/compile] Error 2
make[2]: Leaving directory `/home/OpenWrt/DG834G_12376/trunk'
make[1]: *** [/home/OpenWrt/DG834G_12376/trunk/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/OpenWrt/DG834G_12376/trunk'
make: *** [world] Error 2

I reverting the following change in r12384, but since that didn't work, I suspect the problem is in the upgrading to bridge-utils-1.4.

define Build/Configure 
        (cd $(PKG_BUILD_DIR); \ 
        autoconf; \ 
        ./configure $(CONFIGURE_ARGS) \ 

Sorry if this is a known problem. I didn't see a ticket, but did notice r12377 for a fix of kernel-2.4 systems.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [12388].

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.