Modify

Opened 8 years ago

Closed 8 years ago

#3949 closed defect (invalid)

compiling errors on latest build

Reported by: normunds Owned by: developers
Priority: highest Milestone:
Component: base system Version:
Keywords: adm5120 Cc:

Description (last modified by juhosg)

Platform is wp54, build latest from the trunk. This is the error i get while compiling

/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/linux-2.6.26.3/include/linux/netfilter/xt_sctp.h:68: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__sctp_chunkmap_is_clear'
/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/linux-2.6.26.3/include/linux/netfilter/xt_sctp.h:80: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__sctp_chunkmap_is_all_set'
extensions/libxt_sctp.c: In function 'print_chunks':
extensions/libxt_sctp.c:416: warning: implicit declaration of function '__sctp_chunkmap_is_clear'
extensions/libxt_sctp.c:421: warning: implicit declaration of function '__sctp_chunkmap_is_all_set'
make[4]: *** [extensions/libxt_sctp_sh.o] Error 1
make[4]: Leaving directory `/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/iptables-1.4.0'
make[3]: *** [/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/iptables-1.4.0/.built] Error 2
make[3]: Leaving directory `/mnt/wrt/28082008/trunk/package/iptables'
make[2]: *** [package/iptables/compile] Error 2
make[2]: Leaving directory `/mnt/wrt/28082008/trunk'
make[1]: *** [/mnt/wrt/28082008/trunk/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/mnt/wrt/28082008/trunk'

I'd removed the sctp from compiling ok now next error this is kernel config related

ake[4]: Entering directory `/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/madwifi-trunk-r3314'
Checking requirements... ok.
Checking kernel configuration... FAILED
Please enable PCI support.
make[4]: *** [configcheck] Error 1
make[4]: Leaving directory `/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/madwifi-trunk-r3314'
make[3]: *** [/mnt/wrt/28082008/trunk/build_dir/linux-adm5120_router_le/madwifi-trunk-r3314/.built] Error 2
make[3]: Leaving directory `/mnt/wrt/28082008/trunk/package/madwifi'
make[2]: *** [package/madwifi/compile] Error 2
make[2]: Leaving directory `/mnt/wrt/28082008/trunk'
make[1]: *** [/mnt/wrt/28082008/trunk/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/mnt/wrt/28082008/trunk'
make: *** [world] Error 2

I feel there is some severe bugs in latest trunk as i see something different in kernel_menuconfig than menuconfig (cpu is le in menuconfig and be in kenel_menuconfig)

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by juhosg

  • Description modified (diff)
  • Keywords adm5120 added
  • Resolution set to invalid
  • Status changed from new to closed

Was caused by a broken kernel config, as we've discussed it on IRC.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.