Modify

Opened 8 years ago

Closed 8 years ago

#3996 closed defect (duplicate)

segfault on ipkg install

Reported by: anonymous Owned by: developers
Priority: high Milestone: Kamikaze 7.09
Component: packages Version:
Keywords: ipkg segmentation fault Cc:

Description

When trying "ipkg install libopenssl", ipkg segfaults. Verbose output:

ipkg -V 3 install libopenssl
pkg_info_preinstall_check: updating arch priority for each package
pkg_info_preinstall_check: update file owner list
best installation candidate for libopenssl

adding libopenssl to providers

libopenssl arch=mipsel arch_priority=10 version=0.9.8e-1

Found a valid candidate for the install: libopenssl 0.9.8e-1

arch mipsel (priority 10) supported for pkg libopenssl
Installing libopenssl (0.9.8e-1) to root...
Downloading http://downloads.openwrt.org/kamikaze/7.09/brcm47xx-2.6/packages/./libopenssl_0.9.8e-1_mipsel.ipk
best installation candidate for zlib

adding zlib to providers

zlib arch=mipsel arch_priority=10 version=1.2.3-4
using latest matching zlib 1.2.3-4 mipsel

archival/libipkg/pkg_depends.c:181: satisfying_pkg=(nil)
best installation candidate for zlib

adding zlib to providers

zlib arch=mipsel arch_priority=10 version=1.2.3-4

Found a valid candidate for the install: zlib 1.2.3-4

archival/libipkg/pkg_depends.c:215: satisfying_pkg=0x53fd60
arch mipsel (priority 10) supported for pkg zlib
Installing zlib (1.2.3-4) to root...
Downloading http://downloads.openwrt.org/kamikaze/7.09/brcm47xx-2.6/packages/./zlib_1.2.3-4_mipsel.ipk
Running script /tmp/ipkg-Eicevr/zlib-atEaC1/preinst
Replacing pre-existing file /usr/lib/libz.so owned by package zlib
Replacing pre-existing file /usr/lib/libz.so.1 owned by package zlib
Replacing pre-existing file /usr/lib/libz.so.1.2.3 owned by package zlib

installing maintainer scripts

Segmentation Fault

Platform is WRT54GL v1.1. Code is the generic 2.6 kernel mipsel trx image.

If I don't get a seg fault right away, the system locks up after a short while.

This definitely happens whenever I install a large package. Small packages don't have this problem.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by agb

  • Resolution set to duplicate
  • Status changed from new to closed

Appears to be a duplicate of #2702 which has been resolved by moving to opkg

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.