Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#3999 closed defect (fixed)

kernel panic when upping second master VAP of one basedevice

Reported by: madxray@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: madwifi ar7100 vap master 2 Cc:


Booted freshly compiled trunk version. Created one VAP as master, set essid, set ip address. Create second VAP as master on same basedevice, set essid, try to ifconfig -> segfault (output attached)

On seperate cards it's no problem so far. Association is working, even channel setting works flawless.
Openwrt Version: trunk r12609
Madwifi-Version: madwifi-ng(3314)
Hardware: rb433 + RouterBoard R52 wifi nic(s)

Attachments (2)

openwrt_trunk_2masterVAP_segfault.txt (1.6 KB) - added by madxray@… 8 years ago.
kernel oops caused by ifconfig on second master VAP
kallsyms_openwrt_trunk_two_master_VAP_segfault.txt (1.6 KB) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by madxray@…

kernel oops caused by ifconfig on second master VAP

comment:1 Changed 8 years ago by nbd

please enable KALLSYMS in the kernel using make kernel_menuconfig, rebuild the firmware and then post the new log

comment:2 Changed 8 years ago by madxray@…

Sorry for delay, but yesterday evening I tried to reproduce it with the KALLSYMS enabled and it worked. Now I removed the secondary WiFi NIC and it crashed again. The oops message is attached.

Even with two NICs the devices are created on the same basedevice because when I change the channel on ath0 the channel of ath1 is also changed.

  • reproduction for both cases:

wlanconfig ath0 create wlandev wifi0 wlanmode master
iwconfig ath0 essid "foonet"
ifconfig ath0
wlanconfig ath1 create wlandev wifi0 wlanmode
iwconfig ath1 essid "barnet"
ifconfig ath1
->segfault (only one miniPCI nic attached) respectively working (two miniPCI nics) APs and even STA on one device

comment:3 Changed 8 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r12719

comment:4 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.