Opened 8 years ago

Closed 7 years ago

Last modified 2 years ago

#4087 closed defect (worksforme)

Wrong channels with countrycode=300 for madwifi

Reported by: strzol@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:


When setting countrycode=300 (for Greece) (at /etc/modules.d/50-madwifi), channels 100-140 (at 5GHz band) are missing.

Previous version of madwifi and HAL (on kamikaze 7.09) shows these specific channels normally.
These channels are legal in Greece. Tests are made with Winstron CM9 cards (four of them on x86 platform) that are working normally with kamikaze 7.09 (on x86 and ixp4xx) with countrycode set to 300.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by strzol@…

Forgot to mention that the tests were performed with revision r12926 compiled with the openwrt madwifi branch.

comment:2 Changed 7 years ago by flo'-at-'

Hi Strzol,

did you load ath_ahb also with the option outdoor=1 ?


comment:3 Changed 7 years ago by strzol@…

Excuse my ignorance, but it is the first time that i hear of "ath_ahb".
The only module that i load is "ath_pci". "ath_ahb" is not loaded by deafult.

Should I force the loading of this module as well?

comment:4 Changed 7 years ago by Acinonyx <acinonyxs@…>

countrycode=300 with latest svn and madwifi stable works ok for me. I have all legal indoor channels and all legal outdoor channels when setting outdoor=1

comment:5 Changed 7 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:6 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.