Opened 11 years ago

Closed 9 years ago

Last modified 2 years ago

#420 closed defect (invalid)

awk command is displayed incorrectly in the Command column of ps

Reported by: markoneill@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: busybox awk ps command Cc:


With WhiteRussian RC4, the command

# ps | grep .

shows the following output (other processes deleted for brevity):

  PID  Uid     VmSize Stat Command
 1810 root        384 R    ps
 1811 root        312 S    grep .

But the command

# ps | awk '/./ {print;}'

shows this output:

  PID  Uid     VmSize Stat Command
 1812 root        384 R    ps
 1813 root        596 S    -ash

I would expect the Command string for the awk command to show up as:

  PID  Uid     VmSize Stat Command
 1813 root        596 S    awk '/./ {print;}'

The actual text displayed is the command of the process invoking awk. I.e. if awk is invoked inside a script call test_awk_problem, then the output Command is:

  PID  Uid     VmSize Stat Command
 1821 root        412 R    /bin/sh /usr/local/bin/test_awk_problem

I'm not sure if the problem is with awk, ps or sh, but I guess that the problem is definitely in busybox... ;-)

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by wbx

is it a special OpenWrt issue or more a busybox 1.0 issue? Can you verify with kamikaze and busybox 1.1?

comment:2 Changed 11 years ago by kaloz

  • Milestone set to 2.0

comment:3 Changed 9 years ago by florian

  • Resolution set to invalid
  • Status changed from new to closed

comment:4 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.