Modify

Opened 8 years ago

Closed 8 years ago

#4210 closed defect (duplicate)

Asterisk 1.4.21 problem with post install

Reported by: KillaB Owned by: zandbelt
Priority: high Milestone: Kamikaze 8.09
Component: packages Version:
Keywords: asterisk Cc: agb

Description

I just performed a fresh checkout of 8.09 and built Asterisk 1.4.21 into the base squashfs image.

Everything built fine, but because of the following code in the asterisk-1.4.x Makefile, "/etc/asterisk/asterisk.conf", "/etc/default/asterisk", and "/etc/init.d/asterisk" all ended up with path's to my buildroot host root directory.

define Package/asterisk14/postinst
534	#!/bin/sh
535	ROOT=`echo $${PKG_ROOT} | sed 's:[\/]:\\\&:g' -`
536	/bin/sed -i 's/\ \/etc/\ '$${ROOT}'etc/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
537	/bin/sed -i 's/\ \/var/\ '$${ROOT}'var/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
538	/bin/sed -i 's/\ \/usr/\ '$${ROOT}'usr/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
539	/bin/sed -i 's/^DEST=/DEST='$${ROOT}'/g' $${PKG_ROOT}/etc/init.d/asterisk
540	/bin/sed -i 's/OPTIONS=\"\"/OPTIONS=\"-C\ '$${ROOT}'etc\/asterisk\/asterisk.conf\"/g' $${PKG_ROOT}/etc/default/asterisk
541	endef

Incase it matters, my buildroot environment is Ubuntu 8.10.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by anonymous

Here's an example of what I'm talking about:

root@OpenWrt:/etc/asterisk cat * | grep WGT634U

astetcdir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/etc/asterisk

astmoddir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/usr/lib/asterisk/modules

astvarlibdir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/usr/lib/asterisk

astdatadir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/usr/lib/asterisk

astagidir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/usr/lib/asterisk/agi-bin

astspooldir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/var/spool/asterisk

astrundir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/var/run

astlogdir => /home/jason/OpenWrt/WGT634U/8.09_rc1/8.09/build_dir/mipsel/root-brcm47xx/var/log/asterisk

Also, after modifying to defaults and rebooting there are only three threads running and I'm unable to connect to Asterisk. Could it have something to do with what mazilo was talking about here: http://forum.openwrt.org/viewtopic.php?pid=76206#p76206

comment:2 Changed 8 years ago by anonymous

Dupe of #3530.

comment:3 Changed 8 years ago by zandbelt

  • Owner changed from developers to zandbelt
  • Status changed from new to assigned

comment:4 Changed 8 years ago by zandbelt

  • Resolution set to duplicate
  • Status changed from assigned to closed

duplicate of #3530

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.