Modify

Opened 7 years ago

Closed 7 years ago

#4234 closed defect (duplicate)

ddns-scripts: HTTP Authorization is not working

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

I'm a bit confused why no one complained about this before but on my fresh 8.09RC1 install on a fonera 2.0 the ddns-script is broken for dyndns.org.
The problem is the base64 encoding of the shell_get.sh script.

root@OpenWrt:~# . /usr/lib/ddns/shell_get.sh
root@OpenWrt:~# encode_base64 username:password
c3VyZWFuZW1wOnNhd3NybwBk

On a Ubuntu the linux the result is

~$ echo username:password|base64
dXNlcm5hbWU6cGFzc3dvcmQK

Which is the same http live headers gives my on firefox using the url http://username:password@localhost

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

This is an incomplete version of #4235.

Please close it.

comment:2 Changed 7 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #4235

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.