Modify

Opened 7 years ago

Closed 7 years ago

#4262 closed enhancement (duplicate)

brcm 47xx 2.6.27 update

Reported by: anonymous Owned by: developers
Priority: high Milestone:
Component: kernel Version:
Keywords: Cc:

Description

will the brcm47xx profile ever get a update to 2.6.27? there is already a update from agb available .... see http://downloads.openwrt.org/people/agb/brcm47xx-2.6.27/brcm47xx-2.6.27-2008-10-31.patch

Attachments (1)

0006-add-initial-2.6.27-support-for-brcm47xx.patch (116.9 KB) - added by Hauke <hauke@…> 7 years ago.
[PATCH] add initial 2.6.27 support for brcm47xx

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by loswillios

this happens with 2.6.27 on my WGT634U on high traffic (no swap configured!)

Jan  1 01:11:05 router user.err kernel: swap_free: Bad swap file entry 00000250
Jan  1 01:11:05 router user.err kernel: swap_free: Bad swap file entry 40000000
Jan  1 01:11:05 router user.err kernel: swap_free: Bad swap file entry 78005da8
Jan  1 01:11:05 router user.emerg kernel: Eeek! page_mapcount(page) went negative! (-1)
Jan  1 01:11:05 router user.emerg kernel:   page pfn = 0
Jan  1 01:11:05 router user.emerg kernel:   page->flags = 400
Jan  1 01:11:05 router user.emerg kernel:   page->count = 1
Jan  1 01:11:05 router user.emerg kernel:   page->mapping = 00000000
Jan  1 01:11:05 router user.emerg kernel:   vma->vm_ops = 0x0
Jan  1 01:11:05 router user.warn kernel: Kernel bug detected[#1]:
Jan  1 01:11:05 router user.warn kernel: Cpu 0
Jan  1 01:11:05 router user.warn kernel: $ 0   : 00000000 1000b800 00000000 80250000
Jan  1 01:11:05 router user.warn kernel: $ 4   : 80230000 00000000 00000001 00000000
Jan  1 01:11:05 router user.warn kernel: $ 8   : 80257ed0 80250000 80290000 802a0000
Jan  1 01:11:05 router user.warn kernel: $12   : 80290000 00000000 802949a0 81c15068
Jan  1 01:11:05 router user.warn kernel: $16   : 81000000 fffffffe 81eae8b4 81eae8b4
Jan  1 01:11:05 router user.warn kernel: $20   : 2ac2e000 2ac2e000 003b3e96 ffffffff
Jan  1 01:11:05 router user.warn kernel: $24   : 81eb9ba8 000186a0
Jan  1 01:11:05 router user.warn kernel: $28   : 81eb8000 81eb9df0 ffffffff 800785e4
Jan  1 01:11:05 router user.warn kernel: Hi    : 00000063
Jan  1 01:11:05 router user.warn kernel: Lo    : 53f8e000
Jan  1 01:11:05 router user.warn kernel: epc   : 8007862c page_remove_rmap+0x194/0x334
Jan  1 01:11:05 router user.warn kernel:     Tainted: P
Jan  1 01:11:05 router user.warn kernel: ra    : 800785e4 page_remove_rmap+0x14c/0x334
Jan  1 01:11:05 router user.warn kernel: Status: 1000b803    KERNEL EXL IE
Jan  1 01:11:06 router user.warn kernel: Cause : 00800024
Jan  1 01:11:06 router user.warn kernel: PrId  : 00029007 (Broadcom BCM3302)
Jan  1 01:11:06 router user.warn kernel: Modules linked in: ath_pci wlan_xauth wlan_wep wlan_tkip wlan_ccmp wlan_acl ath_rate_minstrel ath_hal(P) wlan_scan_sta wlan_scan_ap wlan nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_
Jan  1 01:11:06 router user.warn kernel: Process date (pid: 1432, threadinfo=81eb8000, task=81dd2a18, tls=00000000)
Jan  1 01:11:06 router user.warn kernel: Stack : 8102aba0 00000000 00000001 00000000 81000000 2ac16000 81d80058 800700cc
Jan  1 01:11:06 router user.warn kernel:         8189a058 81dc7ea0 81eb9e60 81dc7ea0 00000000 00000081 81e8c2ac 80293004
Jan  1 01:11:06 router user.warn kernel:         81f53520 81e8c2ac 00000001 00000000 81de03c8 81f53520 81f53554 81dd2a18
Jan  1 01:11:06 router user.warn kernel:         00000013 00000001 004080d0 00000000 00000000 800740c4 81eb9e80 00000001
Jan  1 01:11:06 router user.warn kernel:         00000000 ffffffff 81eb9e84 00000000 80293004 0000001b 81f53520 81f53520
Jan  1 01:11:06 router user.warn kernel:         ...
Jan  1 01:11:06 router user.warn kernel: Call Trace:
Jan  1 01:11:06 router user.warn kernel: [<8007862c>] page_remove_rmap+0x194/0x334
Jan  1 01:11:06 router user.warn kernel: [<800700cc>] unmap_vmas+0x3c0/0x5e8
Jan  1 01:11:06 router user.warn kernel: [<800740c4>] exit_mmap+0x70/0x178
Jan  1 01:11:06 router user.warn kernel: [<8002871c>] mmput+0xb4/0x1cc
Jan  1 01:11:06 router user.warn kernel: [<8002d1bc>] exit_mm+0x250/0x284
Jan  1 01:11:06 router user.warn kernel: [<8002f094>] do_exit+0x228/0x810
Jan  1 01:11:06 router user.warn kernel: [<8002f774>] complete_and_exit+0x0/0x24
Jan  1 01:11:06 router user.warn kernel:
Jan  1 01:11:06 router user.warn kernel:
Jan  1 01:11:06 router user.warn kernel: Code: 00b12824  0c015957  2484e46c <0200000d> 8e020010  30420001  10400004  00000000  8e020000
Jan  1 01:11:06 router user.alert kernel: Fixing recursive fault but reboot is needed!

comment:2 Changed 7 years ago by jeroen@…

I am having the same problem here and it is quite annoying, then you finally can download something fast and it gets up to speed and then *oops* and reboot...

Including trace of a non-tainted kernel on 8.09/r13118. I can track svn if wanted, but it doesn't contain 2.6.27 kernel yet for this platform (WRT54GS). Wireless is not in use at the moment as it does not work, but that is fine for me; 2.4 is not an option at all due to PPTP crash bug there which can't be resolved unless by upgrading to 2.6, which is what I did.

eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
printk: 18 messages suppressed.
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
printk: 18 messages suppressed.
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
eth0.0: received packet with  own address as source address
swap_free: Bad swap file entry 00000310
swap_free: Bad swap file entry 40000000
swap_free: Bad swap file entry a00395f8
Eeek! page_mapcount(page) went negative! (-1)
  page pfn = 1000
  page->flags = 400
  page->count = 1
  page->mapping = 00000000
Break instruction in kernel code[#1]:
Cpu 0
$ 0   : 00000000 1000a800 0000001e 80250000
$ 4   : 8024bf40 00000001 00000001 00000000
$ 8   : 8024bf40 80250000 80290000 80290000
$12   : 80290000 00000000 80289588 81eb45e8
$16   : 81020000 2ac16000 80c90058 81e1fd4c
$20   : 2ac2e000 2ac2e000 003b5e85 ffffffff
$24   : 81e3fbd8 000186a0
$28   : 81e3e000 81e3fd38 00000000 8006d5ec
Hi    : 0000006b
Lo    : 4396a800
epc   : 8006d5ec     Not tainted
ra    : 8006d5ec Status: 1000a803    KERNEL EXL IE
Cause : 00800024
PrId  : 00029007 (Broadcom BCM3302)
Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_state nf_conntrack_ipv4 nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables sit tunnel4 ppp_async ppp_generic slhc crc_ccitt b43 mac80211 cfg80211 ipv6 arc4 aes_generic deflate ecb cbc crypto_blkcipher crypto_hash cryptomgr crypto_algapi switch_robo switch_core diag
Process munin-node (pid: 1118, threadinfo=81e3e000, task=81c440a8)
Stack : 8102e760 00000000 00000001 00000000 81020000 80065534 ffffffff 81ed92c0
        00000000 00000000 00000000 01000081 81e482ac 80288004 81cf8a00 81e482ac
        00000001 00000000 81ed4aac 81cf8a00 81e16080 81cf8a00 1000a801 81e85e80
        81ef02e0 00000000 81dec820 800692a4 81e3fdc0 81e2ec50 00000000 ffffffff
        81e3fdc4 00000000 80288004 0000002b 81cf8a00 81cf8a00 8001fea4 00000000
        ...
Call Trace:[<80065534>][<800692a4>][<8001fea4>][<800d7430>][<80082c2c>][<8007d880>][<800b8610>][<800b84a4>][<8000fe8c>][<800819f0>][<800833c8>][<80007848>][<80007824>][<8000b130>][<80002ca0>]

Code: 3c048022  0c008f79  24840b40 <0200000d> 8e040000  8e030010  000427c2  2406028c  30630001
printk: 78 messages suppressed.
eth0.0: received packet with  own address as source address
printk: 11 messages suppressed.
eth0.0: received packet with  own address as source address
printk: 117 messages suppressed.
eth0.0: received packet with  own address as source address
printk: 87 messages suppressed.
eth0.0: received packet with  own address as source address
printk: 97 messages suppressed.
eth0.0: received packet with  own address as source address

As you can see, there is something really weird with the bridging.
Now the fun part:

root@gehenna:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.0014bf72f83c       no              eth0.0

It is not in use, normally I used to have the wireless bridged into it. Maybe temporarily I could try to disable the bridge there.

/me is willing to try out stuff, just give a yell ;)

comment:3 Changed 7 years ago by loswillios

This

eth0.0: received packet with  own address as source address

isn't kernel-related, it also happens with factory 8.09-rc, see #4178

Remove the bridge and try again, that fixes it for me but results in the next error (see my post above)

comment:4 Changed 7 years ago by jeroen@…

I removed the bridge, which helped, up-to now.

Generally a apt-get update/dist-upgrade triggered it nicely to crash the box (but not always send the messages over rsyslog unfortunately, still need to compile in netconsole I guess).

comment:5 Changed 7 years ago by candrews@…

Admins, can you please close this bug as a duplicate of #4169?

Changed 7 years ago by Hauke <hauke@…>

[PATCH] add initial 2.6.27 support for brcm47xx

comment:6 Changed 7 years ago by Hauke <hauke@…>

The attached patch is based on http://dongsupark.de/openwrt/kamikaze-r13514-b43ssb-2.6.27.diff . Some parts of this patch are deleted, because they are not needed any more.

comment:7 Changed 7 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

obsoleted by #4395

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.