Modify

Opened 8 years ago

Closed 7 years ago

Last modified 2 years ago

#4359 closed defect (fixed)

trx tool maxlen argument caused seg fault

Reported by: pawpawyoung@… Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version: Trunk
Keywords: trx Cc:

Description

a bug on trx tool, when you use -m option, you may/maynot got seg fault, cause by realloc().
So attachment is the patch to fix this ;)

Attachments (1)

trx_maxlen_fix.patch (306 bytes) - added by pawpawyoung@… 8 years ago.
trx seg fault caused by -m option

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by pawpawyoung@…

trx seg fault caused by -m option

comment:1 Changed 8 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned
  • Version set to Trunk

comment:2 Changed 7 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Applied in [16641], thanks !

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.