Modify

Opened 7 years ago

Closed 7 years ago

#4360 closed enhancement (wontfix)

mac80211: use compat-wireless-2.6-old for old kernels

Reported by: jal2@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: mac80211, compat-wireless-2.6-old Cc:

Description

The attached patch lets the package mac80211 use compat-wireless-2.6-old (2008-12-03 from the orbit-lab.org server) instead of mac80211 version 2008-08-06 for kernel < 2.6.27. It compiles fine here for target brcm47xx.

I haven't tested the drivers due to a lack of hardware and time, I just needed compat*old urgently for another driver to come (ar9170).

patch 001* disables B43_PIO only otherwise the compilation will break.
So maybe we need more drivers in the Makefile (iwl3945, ...?)

Attachments (1)

mac80211_use_compat-wireless-2.6-old.patch (7.4 KB) - added by jal2@… 7 years ago.
Let mac80211 use compat-wireless-2.6-old. Signed-off-by: Joerg Albert <jal2 at gmx.de>

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by jal2@…

Let mac80211 use compat-wireless-2.6-old. Signed-off-by: Joerg Albert <jal2 at gmx.de>

comment:1 Changed 7 years ago by hauke

  • Resolution set to wontfix
  • Status changed from new to closed

The new compat-wireless-old version are not so good and badly hacked.
We will go to newer kernels to support the recent compat-wireless.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.