Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#4438 closed defect (worksforme)

Kernel build system to bcm63xx fails

Reported by: gandf <gandf@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc: gandf@…

Description

I have no permittion to reopen Ticket #4436. It's the following of this ticket.

On a new system (mandriva on VirtualBox), the problem persists. Here are some screenshots illustrating the problem:
http://www.gandf.info/menuconfig.jpg
http://www.gandf.info/kernel_menuconfig1.jpg
http://www.gandf.info/kernel_menuconfig2.jpg
"Broadcom 63xx based boards" does not show.

We must start a new folder openwrt recovered from SVN. An update to a folder that worked can not reproduce the problem. If it still works, thank you to indicate exactly what you are doing. It worked with an older version of the svn.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by anonymous

As far as I know, you can't find it in the "kernel menuconfig" because it is not supported brcm63xx in linux kernel source, support is done by using files in openwrt repo for this architecture and patches against linux kernel sources.

Greetings!

comment:2 Changed 7 years ago by gandf <gandf@…>

Why patch modifying kernel_menuconfig menu doesn't apply automatically after downloading the kernel and uncompress. This will have a single patch to complete the menu for all targets.

comment:3 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

That is now how things were designed. We do not patch kernel-headers with target specific patches, but we do this when building the kernel modules. No matter how it is done, you should not configure your kernel before your toolchain is ready, which is how things work in OpenWrt. Once the toolchain is setup and your kernel ready to be compiled you can kernel_menuconfig your target.

comment:4 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.