Modify

Opened 8 years ago

Closed 7 years ago

Last modified 2 years ago

#4556 closed defect (worksforme)

srtp_config.h: No such file or directory

Reported by: zoobab Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: srtp_config.h Cc:

Description

Compilation fails.

See the details:

OpenWrt Kamikaze (r14405)

#
# configuration written to .config
#
make[4]: Leaving directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'
make -C /home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13 ARCH=mips KBUILD_HAVE_NLS=no CONFIG_SHELL=/bin/bash include/linux/version.h include/asm
make[4]: Entering directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'
scripts/kconfig/conf -s arch/mips/Kconfig
make[4]: Leaving directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'
gcc: 0: No such file or directory
gcc: unrecognized option '-G'
cc1: error: unrecognized command line option "-mabi=32"
cc1: error: unrecognized command line option "-mno-abicalls"
cc1: error: bad value (r4600) for -march= switch
cc1: error: bad value (r4600) for -mtune= switch
make[4]: Entering directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'

CHK include/linux/version.h
UPD include/linux/version.h
SYMLINK include/asm -> include/asm-mips

make[4]: Leaving directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'
if [ -d /home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13/arch/mips/include/asm ]; then cp -fpR /home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13/arch/mips/include/asm/. /home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13/include/asm-mips/; fi
mkdir -p /home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-dev/usr
make -C /home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13 ARCH=mips KBUILD_HAVE_NLS=no CONFIG_SHELL=/bin/bash CROSS_COMPILE=mipsel-openwrt-linux-uclibc- INSTALL_HDR_PATH="/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-dev/usr/" headers_install
make[4]: Entering directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'

CHK include/linux/version.h
HOSTCC scripts/unifdef

In file included from /usr/local/include/datatypes.h:50,

from /usr/local/include/err.h:49,
from scripts/unifdef.c:67:

/usr/local/include/integers.h:50:67: error: srtp_config.h: No such file or directory
In file included from /usr/local/include/datatypes.h:51,

from /usr/local/include/err.h:49,
from scripts/unifdef.c:67:

/usr/local/include/alloc.h:52: error: expected ')' before 'size'
scripts/unifdef.c: In function 'main':
scripts/unifdef.c:288: warning: implicit declaration of function 'errx'
scripts/unifdef.c:293: warning: implicit declaration of function 'err'
scripts/unifdef.c: In function 'debug':
scripts/unifdef.c:991: warning: implicit declaration of function 'vwarnx'
scripts/unifdef.c: In function 'error':
scripts/unifdef.c:1000: warning: implicit declaration of function 'warnx'
make[5]: * [scripts/unifdef] Error 1
make[4]:
* [headers] Error 2
make[4]: Leaving directory `/home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13'
make[3]: * home/zoobab/soft/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/linux-2.6.27.13/.prepared22e8016fd35100b8f22e2f3f867c7975 Error 2
make[3]: Leaving directory `/home/zoobab/soft/trunk/toolchain/kernel-headers'
make[2]:
* [toolchain/kernel-headers/prepare] Error 2
make[2]: Leaving directory `/home/zoobab/soft/trunk'
make[1]: * home/zoobab/soft/trunk/staging_dir/target-mipsel_uClibc-0.9.29/stamp/.toolchain_install Error 2
make[1]: Leaving directory `/home/zoobab/soft/trunk'
make:
* [world] Error 2

Attachments (1)

bugreport.txt (4.2 KB) - added by zoobab <zoobab@…> 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by zoobab <zoobab@…>

comment:1 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed
  • Version set to 1.0

I cannot reproduce this build failure, please re-open if you happen to see it again.

comment:2 Changed 7 years ago by nico

  • Version changed from 1.0 to Trunk

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.