Modify

Opened 11 years ago

Closed 11 years ago

#46 closed defect (fixed)

diag module loading problem

Reported by: ccowart@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: Cc:

Description

I've recently installed WHITE RUSSIAN (RC3) on a Linksys WRT54G-r1.1. I used the squashfs release.

Kernel 2.4.30-brcm-2

Everything works great except for the diag kernel module.

root@OpenWrt:~# lsmod
Module                  Size  Used by    Tainted: P  
wlcompat               14688   0 (unused)
wl                    423640   0 (unused)
et                     32064   0 (unused)
diag                    2560   1 (initializing)

As the driver hasn't finished initializing, there is no node /proc/sys/diag. As a result, the power LED never stops blinking. I have tried removing the module, but it doesn't succeed. It's stuck in initialization. I've also tried rebooting the router. I also tried modifying the /etc/preinit script to not insmod the module and try loading it manually. It doesn't appear to have worked (because it's reading from the ROM copy at that point, if I understand correctly).

Let me know if there's any other information I can contribute to determine the bug.

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by Vincent Bernat

  • Resolution set to fixed
  • Status changed from new to closed

This has been fixed after rc3, so it will be in rc4. This is in changeset:1969.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.