Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4679 closed defect (worksforme)

apsta mode broken

Reported by: openwrt@… Owned by: developers
Priority: high Milestone: Kamikaze 8.09.1
Component: packages Version: Kamikaze 8.09
Keywords: apsta Cc:

Description

System: 8.09

Hardware: WRT54GL

Setting: Two wifi interfaces for wl0, one in client mode with network wan (pppoe for wl0), one ap with network lan (bridging eth0.0 eth0.1 wl0).

Everything works fine, the client mode connection works, ap signal can be found by client devices, but if an associated device tries to authenticate, syslog throws "user.warn kernel: wl0.1: received packet with own address as source address", ap doesn't respond and authentication times out.

Attachments (0)

Change History (10)

comment:1 in reply to: ↑ description Changed 8 years ago by rudermi@…

System: 8.09, brcm-2.4

Hardware: WHR-HP-G54

I can confirm this bug on a Buffalo WHR-HP-G54 with brcm-2.4 image. It worked flawlessly with 7.09, but with same configuration, it doesn't work on 8.09. While the sta-configuration works and the router can connect to the other access point, the ap-configuration doesn't work. The SSID is visible, but no clients can cannot.

comment:2 Changed 8 years ago by openwrt@…

Both my links use WPA by the way. Turning AP encryption off, it works (since there's no authentication to time out then).

comment:3 Changed 8 years ago by openwrt@…

It's definitely WPA related. Switching the AP's encryption off or WEP, not only fixes the connection issue, but also the "own address as source" message doesn't show up in the log anymore. Haven't had time to test whether doing the same thing with the sta connection has the same effect, but I would guess so. Is there a new WPA component in 8.09 not being able to handle two connections? - or at least in apsta mode.

The same setup worked in 7.09 for me too.

comment:4 Changed 8 years ago by nico

  • Version set to Kamikaze 8.09

comment:5 Changed 8 years ago by florian

  • Milestone changed from Kamikaze to Kamikaze 8.09.1

comment:6 Changed 8 years ago by florian

Can you guys attach your /etc/config/wireless files to help debug this?

comment:7 Changed 8 years ago by openwrt@…

My current one (working):

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'channel' '5'
        option 'disabled' '0'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'ssid' 'Home_ShakaWeb'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'encryption' 'wep'
        option 'key' 'wontgetme'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'wan'
        option 'mode' 'sta'
        option 'ssid' 'DSL_ShakaWeb'
        option 'key' 'metoo'
        option 'encryption' 'psk'

Switching encryption to wpa, it's broken.

comment:8 Changed 8 years ago by nico

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me with r16260

comment:9 Changed 7 years ago by openwrt@…

I can confirm that. :-)

comment:10 Changed 7 years ago by matt1606@…

Encryption doesn't work correctly in kamikaze 8.09.1 with any type of encryption (wep, psk, psk2). Cannot connect to the ap. Only encryption 'none' is working which is definitely not safe.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.