Modify

Opened 7 years ago

Closed 7 years ago

Last modified 22 months ago

#4729 closed defect (fixed)

D-Link 320 rootfs is not writable

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:

Description (last modified by agb)

D-Link dir320
bleeding edge, r14731

flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 2 x8 devices at 0x0 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
Physically mapped flash: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Flash device: 0x800000 at 0x1fc00000
bootloader size: 262144
Updating TRX offsets and length:
old trx = [0x0000001c, 0x0000090c, 0x000be800], len=0x00251000 crc32=0xd395630e
new trx = [0x0000001c, 0x0000090c, 0x000be800], len=0x000be800 crc32=0x2b38f8d3
erase of region [0x40000, 0x20000] on "Physically mapped flash" failed
Done
Creating 4 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "cfe"
0x00040000-0x007e0000 : "linux"
0x000fe800-0x007e0000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=280000, len=560000 
0x00280000-0x007e0000 : "rootfs_data"
0x007e0000-0x00800000 : "nvram"

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by Elphidium

Same with me , brcm47xx, 2.6.28.7, and wireless has a problem loading too.

comment:2 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce such a bug with a Bufallo WHR-HP-G54 or a Linksys WRT54GS v1.1 both running trunk of-the-day.

comment:3 Changed 7 years ago by edo.rus@…

dlink dir-320 did not work with trunk.

duplicate bugreports:
https://dev.openwrt.org/ticket/4988
https://dev.openwrt.org/ticket/5091

comment:4 Changed 7 years ago by agb

  • Description modified (diff)
  • Milestone set to Kamikaze
  • Resolution worksforme deleted
  • Status changed from closed to reopened

"worksforme" on WHR-HP-G54 or WRT54GS is an invalid resolution. This has been confirmed on yet again on DIR-320

See https://dev.openwrt.org/attachment/ticket/5091/dlink_dir320_dmesg.txt for more complete dmesg.

comment:5 Changed 7 years ago by edo <edo.rus@…>

with this trivial patch dir-320 work for me:

Index: target/linux/brcm47xx/files-2.6.28/drivers/mtd/maps/bcm47xx-flash.c
===================================================================
--- target/linux/brcm47xx/files-2.6.28/drivers/mtd/maps/bcm47xx-flash.c (revision 15919)
+++ target/linux/brcm47xx/files-2.6.28/drivers/mtd/maps/bcm47xx-flash.c (working copy)
@@ -378,6 +378,7 @@
        printk("flash init: 0x%08x 0x%08x\n", window, window_size);
        bcm47xx_map.phys = window;
        bcm47xx_map.size = window_size;
+       bcm47xx_map.bankwidth = mcore->flash_buswidth;
        bcm47xx_map.virt = ioremap_nocache(window, window_size);
 #else
        printk("flash init: 0x%08x 0x%08x\n", WINDOW_ADDR, WINDOW_SIZE);

i test asus wl-500gP v1, wl-500gP v2, wl-520gU - patch does not break flash support on these devices.

comment:6 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

applied in r15959, thanks

comment:7 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.