Modify

Opened 9 years ago

Closed 8 years ago

Last modified 3 years ago

#4781 closed defect (fixed)

OpenWRT kill all active connections after dhcp ip renew

Reported by: lesiuk@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

To connect to the Internet I am using another router. For test i set ip renew time to 60 secounds. Every time OpenWRT renew ip all active connections are killed.

This is what i have in syslog.
http://www.nopaste.pl/Source/a9b.txt

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by agb

More information is needed, what release/revision of OpenWrt is this? What target? Could you post /etc/config/network and /etc/config/dhcp so we can try to reproduce?

comment:2 Changed 8 years ago by lesiuk@…

Openwrt 8.09 on asus wl 500g premium v1 (kernel 2.4) - brcm-2.4.

I cant post it(now i dont use openwrt on my router but i really want) but I didnt change anything in this files.

My router is connected to the internet via d-link dsl320t.
http://www.togro.pl/galerie/d/d-link-dsl-320t-modem-ze_699.jpg

I can install openwrt again and give you any informations you need.
You can contact with me via xmmp/jabber: lesiuk@…

comment:3 Changed 8 years ago by retracile <retracile@…>

I see the same issue with 8.09.1 on WRT54GL (both with the 2.4 kernel build and with the 2.6 kernel) behind an AT&T 2wire router. In my case, it happens every 10 minutes. I am not certain, but I think it only happens if the 2wire router is setup to make the WRT54GL be the DMZ ("DMZ Plus" they call it).

The WRT54GL is setup with DHCP for the WAN interface, nothing special in that portion of the config.

In contrast, I tested a WRT160NL with the stock Linksys firmware in place of the WRT54GL running OpenWRT, and did not experience the dropped packet problem.

comment:4 Changed 8 years ago by retracile <retracile@…>

It looks like #4108 may also be related.

comment:5 Changed 8 years ago by retracile <retracile@…>

The iptables change listed in #4108 worked for me.

comment:6 Changed 8 years ago by anonymous

Please add this fix to the newest relase. That will help many people.

comment:7 Changed 8 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

see r17238

comment:8 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.