Modify

Opened 7 years ago

Closed 7 years ago

Last modified 22 months ago

#4836 closed defect (fixed)

Experiemental b43 driver causes a kernel panic in r15044

Reported by: buildster Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: b43 kernel panic Cc:

Description (last modified by hauke)

The experiemntal version (478.104) of b43 driver works pretty well in r14951* on a Broadcom 5352 box. But, in r15044, it causes a kernel panic within a few seconds after booting up. See the following output from serial console. Wireless AP mode and encryption psk2 are used. The wired network (WAN <-> wired LAN) works ok when wifi-device is disabled in /etc/config/wireless. Not sure where to look for culprits.

  • By the way, in r14951, the b43 driver in AP mode could go for hours to days in casual use. But, when under stress (watching p2p IPTV, 200~600 entries in /proc/net/nf_conntrack), it stops responding after 5~30 minutes and has to be restarted with the command wifi. Also, wifi client mode doesn't seem to work at all.

--- serial console output for r15044 ---

b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
cfg80211: Using static regulatory domain info
cfg80211: Regulatory domain: US
        (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
        (2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
        (5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
cfg80211: Calling CRDA for country: US
br-lan: port 1(eth0.0) entering disabled state
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
b43-phy0: Broadcom 5352 WLAN found (core revision 9)
Broadcom 43xx driver loaded [ Features: PLR, Firmware-ID: FW13 ]
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (256 buckets, 1024 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
input: b43-phy0 as /devices/virtual/input/input0
b43 ssb0:3: firmware: requesting b43/ucode5.fw
b43 ssb0:3: firmware: requesting b43/pcm5.fw
b43 ssb0:3: firmware: requesting b43/b0g0initvals5.fw
b43 ssb0:3: firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
b43-phy0: Radio turned on by software
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering disabled state
input: b43-phy0 as /devices/virtual/input/input1
b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
br-lan: topology change detected, propagating
br-lan: port 2(wlan0) entering forwarding state
CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 8017af90, ra == c020ec84
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000d800 00000000 00000040
$ 4   : 808b6cc0 80436be0 1000d801 000000ff
$ 8   : 80438044 808b6800 00000000 00000976
$12   : ffffffed 00000000 80000000 000000ca
$16   : 80436be0 808b6b80 80ffe1c0 8023fdd8
$20   : 80436be0 00000000 00000010 808b6800
$24   : 00000000 c021d8ac
$28   : 8023e000 8023fd50 00000010 c020ec84
Hi    : fffff6e2
Lo    : aaaab3c8
epc   : 8017af90 0x8017af90
    Not tainted
ra    : c020ec84 0xc020ec84
Status: 1000d802    KERNEL EXL
Cause : 0080000c
BadVA : 00000000
PrId  : 00029008 (Broadcom BCM3302)
Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables b43 mac80211 cfg80211 arc4 aes_generic deflate ecb cbc crypto_hash cryptomgr crypto_blkcipher aead crypto_algapi switch_robo switch_core diag
Process swapper (pid: 0, threadinfo=8023e000, task=80240168, tls=00000000)
Stack : 80438034 8023fdd8 80436be0 00000000 808b6800 00000040 80438034 c021d598
        8023fdd8 00000000 00000009 0000000c 8023fe38 80ffe1c0 00000000 80180000
        00000040 80ffe1c0 00000000 00000040 80ffe7d4 808b6b80 80438034 80436be0
        80ffe1c0 0000000c 00000010 00002000 00000010 c021daec 808b6b80 00002000
        8023fe38 00000018 80436be0 808b6800 80ffe1c0 808b6b80 00000000 00000000
        ...
Call Trace:[<c021d598>] 0xc021d598
[<80180000>] 0x80180000
[<c021daec>] 0xc021daec
[<c0206774>] 0xc0206774
[<800326a8>] 0x800326a8
[<800320c0>] 0x800320c0
[<80057bd4>] 0x80057bd4
[<800321d8>] 0x800321d8
[<800321d8>] 0x800321d8
[<80001444>] 0x80001444
[<80043e08>] 0x80043e08
[<80001660>] 0x80001660
[<8000e86c>] 0x8000e86c
[<80001680>] 0x80001680


Code: 8c820004  aca40000  aca20004 <ac450000> 8c820008  ac850004  24420001  ac820008  40016000
Kernel panic - not syncing: Fatal exception in interrupt
Rebooting in 3 seconds..<1>Please stand by while rebooting the system...

Attachments (1)

compat-wireless.patch (1.4 KB) - added by hauke 7 years ago.
compat-wireless-2009-03-28

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by marca56@…

I have the same issue. It's caused by some updates in the WLAN code, I think.

marc.

comment:2 Changed 7 years ago by hauke

  • Description modified (diff)

comment:3 Changed 7 years ago by hauke

Please activate CONFIG_KERNEL_KALLSYMS under "Global build settings" and repost the result to have a readable stack trace.

comment:4 Changed 7 years ago by buildster

Other data points: OpenSource firmware driver (version 410.31754) and the stable b43 driver (version 410.2160) also get a kernel panic.

Here is a bit of call trace for the experimental b43 driver after turning on CONFIG_KERNEL_KALLSYMS. Any help?

device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
cfg80211: Using static regulatory domain info
cfg80211: Regulatory domain: US
        (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
        (2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
        (5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
cfg80211: Calling CRDA for country: US
br-lan: port 1(eth0.0) entering disabled state
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
b43-phy0: Broadcom 5352 WLAN found (core revision 9)
Broadcom 43xx driver loaded [ Features: PLR, Firmware-ID: FW13 ]
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (256 buckets, 1024 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
input: b43-phy0 as /devices/virtual/input/input0
b43 ssb0:3: firmware: requesting b43/ucode5.fw
b43 ssb0:3: firmware: requesting b43/pcm5.fw
b43 ssb0:3: firmware: requesting b43/b0g0initvals5.fw
b43 ssb0:3: firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
b43-phy0: Radio turned on by software
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering disabled state
input: b43-phy0 as /devices/virtual/input/input1
b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
br-lan: topology change detected, propagating
br-lan: port 2(wlan0) entering forwarding state
CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 8017cda0, ra == 

c0217c84
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000d800 00000000 00000040
$ 4   : 809ca4c0 804e1520 1000d801 000000ff
$ 8   : 804ea044 809ca000 00000000 00000980
$12   : ffffffed 00000000 80851a28 000000c7
$16   : 804e1520 809ca380 8095e1c0 80261dd8
$20   : 804e1520 00000000 00000010 809ca000
$24   : 00000000 c02268ac
$28   : 80260000 80261d50 00000010 c0217c84
Hi    : fffff6b4
Lo    : 0000094c
epc   : 8017cda0 skb_queue_tail+0x2c/0x70
    Not tainted
ra    : c0217c84 ieee80211_ibss_rx_mgmt+0x98/0x178 [mac80211]
Status: 1000d802    KERNEL EXL
Cause : 0080000c
BadVA : 00000000
PrId  : 00029008 (Broadcom BCM3302)
Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp 

nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_state nf_conntrack_ipv4 nf_defrag_ipv4 

nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle 

iptable_filter ip_tables xt_tcpudp x_tables b43 mac80211 cfg80211 arc4 aes_generic deflate ecb cbc 

crypto_hash cryptomgr crypto_blkcipher aead crypto_algapi switch_robo switch_core diag
Process swapper (pid: 0, threadinfo=80260000, task=80262168, tls=00000000)
Stack : 804ea034 80261dd8 804e1520 00000000 809ca000 00000040 804ea034 c0226598
        80261dd8 00000980 ffffffed 000000c7 00000055 00000000 00000000 00000000
        00000040 8095e1c0 00000000 00000040 8095e7d4 809ca380 804ea034 804e1520
        8095e1c0 0000000c 00000010 00002000 00000010 c0226aec 809ca380 80265120
        80261e38 00000018 804e1520 809ca000 8095e1c0 809ca380 00000000 00000000
        ...
Call Trace:
[<8017cda0>] skb_queue_tail+0x2c/0x70
[<c0217c84>] ieee80211_ibss_rx_mgmt+0x98/0x178 [mac80211]
[<c0226598>] ieee80211_rx_irqsafe+0x2c68/0x3a7c [mac80211]


Code: 8c820004  aca40000  aca20004 <ac450000> 8c820008  ac850004  24420001  ac820008  40016000
Kernel panic - not syncing: Fatal exception in interrupt
Rebooting in 3 seconds..<1>Please stand by while rebooting the system...

comment:5 Changed 7 years ago by buildster

git-reverting Changeset r15019 ([mac80211] update compat-wireless to 2009-03-24) gets rid of the kernel panic. It goes back the previous working/non-working conditions. I guess compat-wireless 2009-03-24 adds something undesirable.

Changed 7 years ago by hauke

compat-wireless-2009-03-28

comment:6 Changed 7 years ago by hauke

Do you also have the problem with compat-wireless-2009-03-28 ?
The patch is attached. Compat-wireless-2009-03-28 does not work with kernel 2.6.27 temporally, so it will not work on brcm63xx.

comment:7 Changed 7 years ago by mb

This is not a b43 bug.

compat was(is?) temporarly broken in mac80211. ieee80211_ibss_rx_mgmt was called incorrectly for mode!=IBSS. A patch was sent a few days ago to John and to the list.
I didn't check whether it was merged, but I think so since it's quite some time since it was sent.

comment:9 Changed 7 years ago by buildster

Thank you, hauke and mb. That sabotages the panic. I test it on a brcm47xx board with the trunk up to r15058 + compat-wireless.patch, which pulls in compat-wireless-2009-03-28 containing the fix for ieee80211_ibss_rx_mgmt. From square 0 back to square 1. :)

comment:10 Changed 7 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

Thank you for reporting.
This is fixed in r15083.

comment:11 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.