Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#4958 closed defect (worksforme)

compiling error: sstrip

Reported by: desidabri Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: Cc:

Description

15248 version:

I don't know how to eliminate this error during compilation because I don't know at wich kernel makefile option it is related ==

make[3]: Entering directory `/home/desigabri/trunk/openwrt/tools/sstrip'
make[3]: Leaving directory `/home/desigabri/trunk/openwrt/tools/sstrip'
make[3]: Entering directory `/home/desigabri/trunk/openwrt/tools/sstrip'
cp -fpR /home/desigabri/trunk/openwrt/build_dir/host/sstrip/sstrip /home/desigabri/trunk/openwrt/staging_dir/host/bin/
cp: cannot stat `/home/desigabri/trunk/openwrt/build_dir/host/sstrip/sstrip': No such file or directory
make[3]: * home/desigabri/trunk/openwrt/staging_dir/host/stamp/.sstrip_installed Error 1
make[3]: Leaving directory `/home/desigabri/trunk/openwrt/tools/sstrip'
make[2]:
* [tools/sstrip/install] Error 2
make[2]: Leaving directory `/home/desigabri/trunk/openwrt'
make[1]: * home/desigabri/trunk/openwrt/staging_dir/target-mips_uClibc-0.9.30/stamp/.tools_install_nny Error 2
make[1]: Leaving directory `/home/desigabri/trunk/openwrt'
make:
* [world] Error 2

after that I tried to copy sstrip into itself because I thought it was an error into the compiling command as you can see at the 4th line (read the 4th line here) and I got this error. ==

make[3]: Entering directory `/home/desigabri/trunk/openwrt/tools/sstrip'
touch /home/desigabri/trunk/openwrt/build_dir/host/sstrip/.preparedc5c7722ab831822667ce964c971760fd
touch /home/desigabri/trunk/openwrt/build_dir/host/sstrip/.configured
O2 -I/home/desigabri/trunk/openwrt/staging_dir/host/include -I./include -include endian.h -o /home/desigabri/trunk/openwrt/build_dir/host/sstrip/sstrip src/sstrip.c
--: O2: command not found

It seems clearly to me that make looks for sstrip.c file into an not existing directory.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by anonymous

Don't use trunk.

comment:2 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this bug. Please make sure you are building on a supported platform and with no local modification.

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.