Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5171 closed defect (worksforme)

gphoto2 doesn't compile due to library issue

Reported by: Maddes <maddes_trac@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Trunk: r15926
Feed "packages": same revision as trunk, all packages installed
Feed "luci": r4577, all packages installed

Build Environment: Debian 5.0

Target System: Marvel Orion
Target Image: SquashFS image
Kernel: 2.6.28
Global build settings: Select all packages by default
Call: make clean, make V=99

mkdir .libs
libtool: link: warning: library `/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libltdl.la' was moved.
libtool: link: warning: library `/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libltdl.la' was moved.
arm-openwrt-linux-uclibcgnueabi-gcc -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/include -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/include -I.. -I../gphoto2 -DLOCALEDIR=\"/usr/share/locale\" -Wall -Wmissing-declarations -Wmissing-prototypes -g -D_GPHOTO2_INTERNAL_CODE -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/include -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/include -Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time -fhonour-copts -msoft-float -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/include/gphoto2 -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/include -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/include -Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time -fhonour-copts -msoft-float -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/include -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/include -Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time -fhonour-copts -msoft-float -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/include -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/include -Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time -fhonour-copts -msoft-float -Wall -g -o gphoto2 gphoto2-gphoto2-cmd-capture.o gphoto2-actions.o gphoto2-foreach.o gphoto2-gp-params.o gphoto2-spawnve.o gphoto2-main.o gphoto2-version.o gphoto2-range.o gphoto2-shell.o  -L/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/usr/lib -L/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib -L/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib -L/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/lib -laa -lpthread -lexif -lgphoto2 -lgphoto2_port /home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libltdl.so -ldl -lpopt
/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/usr/lib/gcc/arm-openwrt-linux-uclibcgnueabi/4.1.2/../../../../arm-openwrt-linux-uclibcgnueabi/bin/ld: warning: libncurses.so.5, needed by /home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so, not found (try using -rpath or -rpath-link)
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `termattrs'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `endwin'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `nl'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `echo'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `nocbreak'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `wrefresh'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `cbreak'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `waddnstr'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `nonl'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `keypad'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `noecho'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `intrflush'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `initscr'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `wmove'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `curs_set'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `wgetch'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `stdscr'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `wclear'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `nodelay'
/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-0.9.29/usr/lib/libaa.so: undefined reference to `mousemask'
collect2: ld returned 1 exit status
make[6]: *** [gphoto2] Error 1
make[6]: Leaving directory `/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-0.9.29/gphoto2-2.4.1/gphoto2'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-0.9.29/gphoto2-2.4.1'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-0.9.29/gphoto2-2.4.1'
make[3]: *** [/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-0.9.29/gphoto2-2.4.1/.built] Error 2
make[3]: Leaving directory `/home/openwrt/kamikaze-trunk/feeds/packages/multimedia/gphoto2'
make[2]: *** [package/feeds/packages/gphoto2/compile] Error 2

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this bug with Marvell Orion, can you make sure all dependencies are resolved ?

comment:2 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.