Modify

Opened 7 years ago

Closed 2 years ago

Last modified 2 years ago

#5234 closed defect (wontfix)

robocfg show displays incorrect port descriptions on WRT54GL

Reported by: thomas@… Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: robocfg, wrt54gl Cc:

Description

The "robocfg show" command displays the following output on WRT54GL

probing eth1
SIOCETHTOOL: No such device
probing eth0
Switch: enabled
Port 0(W):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 1(4):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 2(3): 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 3(2):  10HD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 4(1): 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 5(C): 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x enabled mac_check mac_hash
vlan0: 0 1 2 3 5t
vlan1: 4 5t

However, port 4 is WAN (W) on this router and port 0 is labelled 4 and so on. The problem is that this is hardcoded in robocfg:

char ports[6] = { 'W', '4', '3', '2', '1', 'C' };

While on WRT54GL, this would be correct:

char ports[6] = { '4', '3', '2', '1', 'W', 'C' };

It's probably different on other devices, so this shouldn't be hardcoded, but autodetected based on the device type somehow.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by florian

robocfg is pretty outdated actually not sure it is worth fixing things with it.

comment:2 Changed 2 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

swconfig is now used for Broadcom switches.

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.