Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5297 closed defect (fixed)

[ppc40x] can't mount system during boot

Reported by: Marcin Tabakiernik <mtabakiernik@…> Owned by: kaloz
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ppc40 magicbox Cc:

Description

Hello.
I can't get to start OpenWrt on ppc40x device - Magicbox v2.
Using default config I get error during boot, that root fs system can't be mounted.

I can't figure out why. Tried changing a lot in kernel but it didn't help.

The error I get:

ffc00000.nor_flash: Found 1 x16 devices at 0x0 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
ffc00000.nor_flash: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
RedBoot partition parsing not available
Creating 3 MTD partitions on "ffc00000.nor_flash":
0x00000000-0x003c0000 : "linux"
0x00100000-0x003c0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
split_squashfs: no squashfs found in "ffc00000.nor_flash"
0x003c0000-0x003f0000 : "u-boot"
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
List of all partitions:
1f00            3840 mtdblock0 (driver?)
1f01            2816 mtdblock1 (driver?)
1f02             192 mtdblock2 (driver?)
No filesystem could mount root, tried:  squashfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,1)
Rebooting in 180 seconds..

Uboot:

=> printenv

baudrate=115200
ethaddr=00:50:C2:1E:CF:FE
eth1addr=00:50:C2:1E:CF:FD
kernel_addr=ffC00000
bootdelay=5
bootm=ffC00000
bootcmd=bootm ffc00000
ipaddr=10.5.100.1
serverip=10.5.100.2
bootargs=console=ttyS0,115200 root=/dev/mtdblock1 rootfstype=squashfs noinitrd init=/etc/preinit

stdin=serial
stdout=serial
stderr=serial
ver=U-Boot 1.1.2 (Apr 14 2007 - 16:51:19)

Attachments (3)

005-magicboxv1.dts.patch (538 bytes) - added by Sebastian Pflieger <openwrt@…> 7 years ago.
magicbox v1 dts update
006-magicboxv2.dts.patch (538 bytes) - added by Sebastian Pflieger <openwrt@…> 7 years ago.
magicbox v2 dts update
image-Makefile.patch (1.4 KB) - added by Sebastian Pflieger <openwrt@…> 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Sebastian Pflieger <openwrt@…>

magicbox v1 dts update

Changed 7 years ago by Sebastian Pflieger <openwrt@…>

magicbox v2 dts update

comment:1 Changed 7 years ago by Sebastian Pflieger <openwrt@…>

Thats because the kernel got larger than 1Mb. The rootfs MTD partition begins at the 1Mb (0x100000) but there is stille the kernel. I updated the device tree an the image makefile to fix this.

Changed 7 years ago by Sebastian Pflieger <openwrt@…>

comment:2 Changed 7 years ago by mtabakiernik@…

So obvious!
Why didn't I come on that...
I found another bug for magicbox. While using jffs2 image during boot system is being erased. Changing erase block size (the bs parametr in Makefile) from 128 to 64 helped.
Later I'll post patch.

comment:3 Changed 7 years ago by florian

  • Owner changed from developers to kaloz

comment:4 Changed 7 years ago by juhosg

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [16906].

comment:5 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.