Modify

Opened 7 years ago

Closed 6 years ago

Last modified 22 months ago

#5308 closed defect (fixed)

broadcom-wl: broadcom.sh doesn't support multiple wireless interfaces

Reported by: mleinart@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I submitted a patch on this a while ago but looks like it was lost.

Basically, broadcom.sh ignores interfaces other than wl0. This is mainly because wl0 is hardcoded at several points in the script instead of the passed in parameter (for device) being used. Additionally, the wlc commands dont explicity specify an interface (with the iface option) so the first (wl0) is always used. This is a problem with dual-radio broadcom routers such as wrt600N and wrt610N.

Also included is an update to the detect function which will create configs for each adapter with non-conflicting ssids (e.g. OpenWrt, OpenWrt1, OpenWrt2, etc)

Attached patch is diffed against r16256 in trunk

Attachments (1)

broadcom-wl-multiradio.patch (1.9 KB) - added by mleinart@… 7 years ago.
Patch to broadcom.sh in broadcom-wl package

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by mleinart@…

Patch to broadcom.sh in broadcom-wl package

comment:1 Changed 7 years ago by mleinart@…

This appears to be the cause of ticket #4258

comment:2 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comitted in r19273 - thanks!

comment:3 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.