Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5309 closed defect (fixed)

ipmitool doesn't compile, due to error caused by patch

Reported by: Maddes <maddes_trac@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:


Trunk: r16376
Feed "packages": same revision as trunk, all packages installed
Feed "luci": 4803, all packages installed

Build Environment: Debian 5.0


make distclean (backup downloads before, otherwise 'make clean' plus 'rm .config' should be suffcient too)
scripts/feeds update packages luci
scripts/feeds install -a -p packages
scripts/feeds install -a -p luci
scripts/feeds uninstall classpath fluxbox (to avoid stops by other compilation errors)
make menuconfig
     --> Target System: Marvel Orion (ARM, Kernel 2.6.28)[[BR]]
     --> Target Image: SquashFS image (default)[[BR]]
     --> Global build settings: Select all packages by default[[BR]]
make V=99

Log with error message:

if /bin/sh ../libtool --silent --tag=CC --mode=compile arm-openwrt-linux-uclibcgnueabi-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include  -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc- -I/home/openwrt/kamikaze-trunk/staging_dir/target-arm_uClibc-   -Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time -fhonour-copts -msoft-float  -fno-strict-aliasing -MT ipmi_sdr.lo -MD -MP -MF ".deps/ipmi_sdr.Tpo" -c -o ipmi_sdr.lo ipmi_sdr.c; \
        then mv -f ".deps/ipmi_sdr.Tpo" ".deps/ipmi_sdr.Plo"; else rm -f ".deps/ipmi_sdr.Tpo"; exit 1; fi
ipmi_sdr.c:4365: error: expected identifier or '(' before 'sizeof'
make[6]: *** [ipmi_sdr.lo] Error 1
make[6]: Leaving directory `/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-'
make[3]: *** [/home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-] Error 2
make[3]: Leaving directory `/home/openwrt/kamikaze-trunk/feeds/packages/utils/ipmitool'

The line 4365 is coming from the patch "100-cubic_root.patch":

  #ifdef ANSIPROT
  extern double frexp ( double, int * );
  extern double ldexp ( double, int );
  extern int isnan ( double );
  extern int isfinite ( double );
  double frexp(), ldexp();
> int isnan(), isfinite();

Same error occurs when I go back to 1.8.9.
The current 1.8.11 release stops due to test not being possible when cross-compiling.

Attachments (1)

100-cubic_root.patch (2.8 KB) - added by guillermo@… 7 years ago.
Modified 100-cubic_root.patch file according to the trunk version of the same one.-

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by guillermo@…

Modified 100-cubic_root.patch file according to the trunk version of the same one.-

comment:1 Changed 7 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in [16599], thanks !

comment:2 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.