Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5312 closed defect (worksforme)

b43 not working on wl500gp [r16366]

Reported by: Sergey Lungu <sergey.lungu@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: b43 Cc:

Description

b43 driver seems to be broken on wl500gp in pretty recent trunk (r16366). First off all the boot process hangs for a really long time and after all dmesg's tail contains the following messages:

b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
device wlan0 entered promiscuous mode
b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
device wlan0 left promiscuous mode
br-lan: port 2(wlan0) entering disabled state
b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
device wlan0 entered promiscuous mode
b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43-open/ucode5.fw
b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

Of course, the wireless access does not work, despite the fact that the file reported as missing (ucode5.fw) actually exists.

My /etc/config/wireless follows.

config wifi-device wlan0
    option type       "mac80211"
    option channel    "5"

config wifi-iface
    option device     "wlan0"
    option network    "lan"
    option mode       "ap"
    option ssid       "xxx"
    option hidden     "1"
    option encryption "psk2"
    option key        "xxx"

Attachments (1)

boot.txt (4.9 KB) - added by tschenser@… 7 years ago.
Bootlog of normal Boot

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

It complains about the firmware not being available, please make sure that you updated your trunk copy and rebuilt your hotplug2 package. This bug is fixed with [16231].

comment:2 follow-up: Changed 7 years ago by Sergey Lungu <sergey.lungu@…>

Nope, 16231 does not fix this issue. First of all, as I have already mentioned in the subject, I had 16366 and it was a full rebuild and full reinstall, so I had 16231 and updated hotplug2 package.

Anyway, I have updated to 16404 and made another full rebuild and reinstall --- same issue.

So, I would like this ticket to be reopened. Maybe I can supply some more information to help in finding the cause of the issue?

comment:3 in reply to: ↑ 2 Changed 7 years ago by Sergey Lungu <sergey.lungu@…>

A small note: wireless access does not work after boot, but if I manually enable it (eg, by running /etc/init.d/network script), then it comes up.

comment:4 follow-up: Changed 7 years ago by amcnabb@…

I'm having this problem, too, with a fresh checkout from trunk (revision 17419). I agree with Sergey that this should be reopened.

By the way, bug #5477 seems to be a duplicate of this ticket.

comment:5 in reply to: ↑ 4 Changed 7 years ago by Sergey Lungu <sergey.lungu@…>

Replying to amcnabb@…:

I'm having this problem, too, with a fresh checkout from trunk (revision 17419). I agree with Sergey that this should be reopened.

By the way, bug #5477 seems to be a duplicate of this ticket.

Do you have both b43 and b43-legacy installed?

comment:6 Changed 7 years ago by amcnabb@…

I believe that both b43 and b43-legacy were installed and loaded, though I can double check this evening.

comment:7 Changed 7 years ago by anonymous

I just confirmed that both b43 and b43legacy are installed.

comment:8 Changed 7 years ago by anonymous

By the way, sometimes I have seen the "not found" errors as above. Other times, I have seen errors like the following:

b43 ssb1:0: firmware: requesting b43/ucode5.fw
b43 ssb1:0: firmware: requesting b43/pcm5.fw
b43 ssb1:0: firmware: requesting b43/b0g0initvals5.fw
b43 ssb1:0: firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy1: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy1 ERROR: Initial Values Firmware file-format error.
b43-phy1 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

Changed 7 years ago by tschenser@…

Bootlog of normal Boot

comment:9 Changed 7 years ago by tschenser@…

I expire the same problem on my WRT54GL 1.1 (ipv6 enbled) as well when i refer the wlan0 interface directly in /etc/config/network. If I use it as a bridged interface everything seems to be well (see attached serial log 'boot.txt'). If I use the wlan0 interface as iface in /etc/config/network the boot process hangs right after the line 'IPv6 over IPv4 tunneling driver'. After a while i get the same messages as described in this ticket. Could it be a race condition between firmware loading and ipv6 loading?

comment:10 Changed 7 years ago by anonymous

Hi,

can confirm the behaviour described by tschenser. When wlan0 is bridged to eth0.1 no error occurs. However, when it is configered as own interface in /etc/config/network the boot process will hang with the following error message occurring repeatedly.
On my box no IPv4 is installed, so maybe this is another issue

Jan 1 01:04:34 garm user.err kernel: b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
Jan 1 01:04:34 garm user.err kernel: b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
Jan 1 01:04:34 garm user.err kernel: b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

comment:11 Changed 7 years ago by anonymous

Meant of course no IPv6 installed....

comment:12 Changed 7 years ago by reindyr@…

Im am running openwrt trunk on a WRT54GS v2.0 box and have experienced the same problems when NOT bridging wlan0 and eth0.1.

As a workaround I have created a patch for /etc/hotplug.d/net/10-net. Now everything works to my satisfaction. I would greatly appreciate if you accept this patch into trunk.

Cheers

reindyr

============================================================

--- /tmp/10-net Thu Sep 17 13:48:03 2009
+++ 10-net Thu Sep 17 13:49:08 2009
@@ -10,8 +10,10 @@

}

# PPP devices are configured by pppd, no need to run setup_interface here

+ # WLAN devices are configured by wifi, no need to run setup_interface here

case "$INTERFACE" in

ppp*) return 0;;

+ wlan*) return 0;;

esac

scan_interfaces

comment:13 Changed 7 years ago by anonymous

Great, i applied the patch and now wifi behaves es expected. Great job! Please apply the patch to current trunk.

comment:14 Changed 7 years ago by tschenser@…

Just for notice, the comment above was mine.

comment:15 Changed 6 years ago by anonymous

This patch allowed my WRT54GL boot up a lot quicker. Hope it makes rc5.

comment:16 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.