Modify

Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#5421 closed defect (worksforme)

kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/lib/gcc/mipsel-openwrt-linux-uclibc/4.4.0/libgcc_initial.a: No such file or directory

Reported by: Craig <candrews@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: Cc:

Description

I updated to r16554, and tried to compile for brcm47xx. I set the gcc version 4.4, and the uClibc version to 0.9.30.1. I ended up with this error during make:

make[3]: Entering directory `/home/candrews/kamikaze/toolchain/uClibc'
/home/candrews/kamikaze/staging_dir/host/bin/sed -i -e 's,^CROSS=.*,CROSS=mipsel-openwrt-linux-uclibc-,g' /home/candrews/kamikaze/build_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/uClibc-0.9.30.1/Rules.mak
PATH=/home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/bin:/home/candrews/kamikaze/staging_dir/host/bin:/home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/bin:/home/candrews/kamikaze/staging_dir/host/bin:/home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/bin:/home/candrews/kamikaze/staging_dir/host/bin:/etc/java-config-2/current-system-vm/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games/bin: make -C /home/candrews/kamikaze/build_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/uClibc-0.9.30.1 AR=mipsel-openwrt-linux-uclibc-ar AS="ccache mipsel-openwrt-linux-uclibc-gcc -c -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts" LD=mipsel-openwrt-linux-uclibc-ld NM=mipsel-openwrt-linux-uclibc-nm CC="ccache mipsel-openwrt-linux-uclibc-gcc" GCC="ccache mipsel-openwrt-linux-uclibc-gcc" CXX="mipsel-openwrt-linux-uclibc-g++" RANLIB=mipsel-openwrt-linux-uclibc-ranlib STRIP=mipsel-openwrt-linux-uclibc-strip OBJCOPY=mipsel-openwrt-linux-uclibc-objcopy OBJDUMP=mipsel-openwrt-linux-uclibc-objdump SIZE=mipsel-openwrt-linux-uclibc-size DEVEL_PREFIX=/usr/ RUNTIME_PREFIX=/ HOSTCC="gcc" CPU_CFLAGS="-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts" LIBGCC="/home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/lib/gcc/mipsel-openwrt-linux-uclibc/4.4.0/libgcc_initial.a" DOSTRIP="" PREFIX= all
make[4]: Entering directory `/home/candrews/kamikaze/build_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/uClibc-0.9.30.1'
install -d lib/
rm -f lib/ld-uClibc.so lib/ld-uClibc.so.0 lib/ld-uClibc-0.9.30.1.so
ccache mipsel-openwrt-linux-uclibc-gcc -Wl,-EL -Wl,-melf32ltsmip -Wl,-shared -Wl,--warn-common -Wl,--warn-once -Wl,-z,combreloc -Wl,-z,relro -Wl,-z,defs   -Wl,-e,_start -Wl,-z,now -Wl,-Bsymbolic -Wl,--export-dynamic -Wl,--sort-common -Wl,--discard-locals -Wl,--discard-all -Wl,--no-undefined -Wl,-soname=ld-uClibc.so.0 -nostdlib -o lib/ld-uClibc-0.9.30.1.so  -Wl,--whole-archive ldso/ldso/ld-uClibc_so.a -Wl,--no-whole-archive  /home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/lib/gcc/mipsel-openwrt-linux-uclibc/4.4.0/libgcc_initial.a 
mipsel-openwrt-linux-uclibc-gcc: /home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/lib/gcc/mipsel-openwrt-linux-uclibc/4.4.0/libgcc_initial.a: No such file or directory
make[4]: *** [lib/ld-uClibc.so] Error 1
make[4]: Leaving directory `/home/candrews/kamikaze/build_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/uClibc-0.9.30.1'
make[3]: *** [/home/candrews/kamikaze/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/stamp/.uclibc_installed] Error 2
make[3]: Leaving directory `/home/candrews/kamikaze/toolchain/uClibc'
make[2]: *** [toolchain/uClibc/compile] Error 2
make[2]: Leaving directory `/home/candrews/kamikaze'
make[1]: *** [/home/candrews/kamikaze/staging_dir/target-mipsel_uClibc-0.9.30.1/stamp/.toolchain_install] Error 2
make[1]: Leaving directory `/home/candrews/kamikaze'
make: *** [world] Error 2

I am attaching my .config

Attachments (1)

.config (90.9 KB) - added by Craig <candrews@…> 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Craig <candrews@…>

comment:1 Changed 7 years ago by Craig <candrews@…>

The same configuration using gcc 4.3.3 works fine.

comment:2 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the bug here. Please issue a make distclean if this still does not solve your problem.

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.